2

I was trying to update OpenGL (A problem for another day, but if you can help on that front it also will be appreciated) when I started getting so problems So I had done:

root@Friithian:/home/gunqqer# apt autoremove  
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
 libdrm-dev : Depends: libdrm-amdgpu1 (= 2.4.89+git1712180630.831036~oibaf~x) but 2.4.83-1~16.04.1 is installed
 libgl1-mesa-dri : Depends: libdrm-amdgpu1 (>= 2.4.89+git1712180630.831036~oibaf~x) but 2.4.83-1~16.04.1 is installed
 libgl1-mesa-dri:i386 : Depends: libdrm-amdgpu1:i386 (>= 2.4.89+git1712180630.831036~oibaf~x) but 2.4.83-1~16.04.1 is installed
 mesa-va-drivers : Depends: libdrm-amdgpu1 (>= 2.4.89+git1712180630.831036~oibaf~x) but 2.4.83-1~16.04.1 is installed
 mesa-vdpau-drivers : Depends: libdrm-amdgpu1 (>= 2.4.89+git1712180630.831036~oibaf~x) but 2.4.83-1~16.04.1 is installed
E: Unmet dependencies. Try using -f.

So then I did

root@Friithian:/home/gunqqer# apt-get -f install
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following package was automatically installed and is no longer required:
  libdrm-common
Use 'sudo apt autoremove' to remove it.
The following additional packages will be installed:
  libdrm-amdgpu1 libdrm-amdgpu1:i386
The following packages will be upgraded:
  libdrm-amdgpu1 libdrm-amdgpu1:i386
2 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
15 not fully installed or removed.
Need to get 0 B/60.1 kB of archives.
After this operation, 16.4 kB of additional disk space will be used.
Do you want to continue? [Y/n] y
(Reading database ... 232943 files and directories currently installed.)
Preparing to unpack .../libdrm-amdgpu1_2.4.89+git1712180630.831036~oibaf~x_amd64.deb ...
De-configuring libdrm-amdgpu1:i386 (2.4.83-1~16.04.1) ...
Unpacking libdrm-amdgpu1:amd64 (2.4.89+git1712180630.831036~oibaf~x) over (2.4.83-1~16.04.1) ...
dpkg: error processing archive /var/cache/apt/archives/libdrm-amdgpu1_2.4.89+git1712180630.831036~oibaf~x_amd64.deb (--unpack):
 trying to overwrite '/usr/share/libdrm/amdgpu.ids', which is also in package libdrm-common 2.4.83-1~16.04.1
Preparing to unpack .../libdrm-amdgpu1_2.4.89+git1712180630.831036~oibaf~x_i386.deb ...
De-configuring libdrm-amdgpu1:amd64 (2.4.83-1~16.04.1) ...
Unpacking libdrm-amdgpu1:i386 (2.4.89+git1712180630.831036~oibaf~x) over (2.4.83-1~16.04.1) ...
dpkg: error processing archive /var/cache/apt/archives/libdrm-amdgpu1_2.4.89+git1712180630.831036~oibaf~x_i386.deb (--unpack):
 trying to overwrite '/usr/share/libdrm/amdgpu.ids', which is also in package libdrm-common 2.4.83-1~16.04.1
Processing triggers for libc-bin (2.23-0ubuntu9) ...
Errors were encountered while processing:
 /var/cache/apt/archives/libdrm-amdgpu1_2.4.89+git1712180630.831036~oibaf~x_amd64.deb
 /var/cache/apt/archives/libdrm-amdgpu1_2.4.89+git1712180630.831036~oibaf~x_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

So, I don't know what to do to fix this. If you need me to run a command and tell you the results I can.

4

It is caused by default dpkg overwriting status. dpkg won't overwrite without your permission into shared folder. The workaround:

Press Ctrl+Alt+T and do:

sudo apt-get -o Dpkg::Options::="--force-overwrite" -f install

Hope it helps...

2
  • Hey this seems to have fixed my problem! Thank you so much, now on to fixing other things!
    – Gunqqer
    Jan 6 '18 at 23:57
  • Please, accept my answer if that solved your question.
    – Olimjon
    Jan 6 '18 at 23:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.