2

I am trying to send a simple notification with

notify-send "Linux"    

And nothing shows up. However

notify-send "Linux" -t 0

shows a dialog box like this

enter image description here

How can I make notify-send to send a normal notification in the top corner?

7
  • The -t parameter specifies the amount of time. Setting it to 0 means "forever" so it turns into a dialog box where you have to acknowledge the message. If you changed time to 5 seconds it will appear as a normal message bubble in the top right hand corner. – WinEunuuchs2Unix Jan 6 '18 at 15:01
  • @WinEunuuchs2Unix Thanks. notify-send "Testing" -t 5 doesn't show any notification at all. – ChillarAnand Jan 6 '18 at 15:08
  • I tested it on my system and it works fine. What version of Ubuntu are you using? What make and model of computer? One screen or more? – WinEunuuchs2Unix Jan 6 '18 at 15:09
  • It used to work on 12.04. I am using 16.04 asus laptop with 1 screen. – ChillarAnand Jan 6 '18 at 15:26
  • Was it a fresh install of 16.04 or an upgrade? I'm using fresh install of 16.04 on this laptop and it works fine. On old laptop it was upgraded from 14.04 to 16.04 and it works fine there too. Do you get notification bubbles from other apps like low battery warnings? Try this: notify-send --urgency=critical "Critical test" which should always work. – WinEunuuchs2Unix Jan 6 '18 at 15:38
1

notify-send time out parameter

The notify-send time out parameter is set with -t switch. In your case it is -t 0 or 0 seconds which is translated as "forever". As such rather than a normal pop-up bubble in the top right it is displayed as a dialog box.

So for this part of your question the system is performing normally.

Only critical notifications are appearing

The urgency level can be passed as "low", "normal" or "critical" using the -u switch. In your environment (for reasons yet to be discovered) only messages with urgency level "critical" are appearing:

notify-send --urgency=critical "Critical test"

If you're watching a video the normal urgency messages will not appear. This is known as "Do Not Disturb" mode introduced in Ubuntu 10.04.

I tested this in both FireFox and Chrome in both full screen and non-full screen under Kernel versions 4.4.0-104 and 4.4.10-42.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.