0

At first wifi didn't work at all (nothing showing up). But after following some guides I think I solved it by disabling some hard-blocking settings.

Now however I have wifi for 1/2 minutes, then I lose it for a few minutes, and the cycle repeats. while the connection is lost, the icon says I'm still connected, and I can still see available networks. But attempting reconnect will fail. I dual-boot, and on windows 10 wifi works flawlessly.

I tried turning off IPv6, since it did not work I enabled it again. I also tried some solution that apparently was not meant for my card, so I reverted it.

info:

Network cards (running lshw -class network):

*-network
    description: Wireless interface
    product: RTL8821AE 802.11ac PCIe Wireless Network Adapter
    vendor: Realtek Semiconductor Co., Ltd.
    physical id: 0
    bus info: pci@0000:03:00.0
    logical name: wlp3s0
    version: 00
    serial: 60:14:b3:b4:f5:bb
    width: 64 bits
    clock: 33MHz
    capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
    configuration: broadcast=yes driver=rtl8821ae driverversion=4.10.0-42-generic firmware=N/A ip=192.168.38.108 latency=0 link=yes multicast=yes wireless=IEEE 802.11
    resources: irq:329 ioport:4000(size=256) memory:a4200000-a4203fff
*-network
    description: Ethernet interface
    product: RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
    vendor: Realtek Semiconductor Co., Ltd.
    physical id: 0
    bus info: pci@0000:04:00.0
    logical name: enp4s0
    version: 10
    serial: 54:e1:ad:9b:4e:af
    size: 1Gbit/s
    capacity: 1Gbit/s
    width: 64 bits
    clock: 33MHz
    capabilities: pm msi pciexpress msix vpd bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
    configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=full firmware=rtl8168g-3_0.0.1 04/23/13 ip=192.168.38.110 latency=0 link=yes multicast=yes port=MII speed=1Gbit/s
    resources: irq:321 ioport:3000(size=256) memory:a4104000-a4104fff memory:a4100000-a4103fff:3000(size=256) memory:a4104000-a4104fff memory:a4100000-a4103fff

There is no softblock or hardblock

Usb wireless card (lsusb):

Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 003: ID 04f2:b57e Chicony Electronics Co., Ltd 
Bus 001 Device 002: ID 046d:c051 Logitech, Inc. G3 (MX518) Optical Mouse
Bus 001 Device 004: ID 0bda:0821 Realtek Semiconductor Corp. 
Bus 001 Device 006: ID 04e8:6860 Samsung Electronics Co., Ltd Galaxy (MTP)
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

PCI wireless card (lscpi)

00:00.0 Host bridge: Intel Corporation Device 5910 (rev 05)
00:01.0 PCI bridge: Intel Corporation Sky Lake PCIe Controller (x16) (rev 05)
00:02.0 VGA compatible controller: Intel Corporation Device 591b (rev 04)
00:14.0 USB controller: Intel Corporation Sunrise Point-H USB 3.0 xHCI Controller (rev 31)
00:14.2 Signal processing controller: Intel Corporation Sunrise Point-H Thermal subsystem (rev 31)
00:16.0 Communication controller: Intel Corporation Sunrise Point-H CSME HECI #1 (rev 31)
00:17.0 SATA controller: Intel Corporation Sunrise Point-H SATA Controller [AHCI mode] (rev 31)
00:1c.0 PCI bridge: Intel Corporation Sunrise Point-H PCI Express Root Port #2 (rev f1)
00:1c.2 PCI bridge: Intel Corporation Sunrise Point-H PCI Express Root Port #3 (rev f1)
00:1c.3 PCI bridge: Intel Corporation Sunrise Point-H PCI Express Root Port #4 (rev f1)
00:1d.0 PCI bridge: Intel Corporation Sunrise Point-H PCI Express Root Port #9 (rev f1)
00:1f.0 ISA bridge: Intel Corporation Sunrise Point-H LPC Controller (rev 31)
00:1f.2 Memory controller: Intel Corporation Sunrise Point-H PMC (rev 31)
00:1f.3 Audio device: Intel Corporation Device a171 (rev 31)
00:1f.4 SMBus: Intel Corporation Sunrise Point-H SMBus (rev 31)
01:00.0 3D controller: NVIDIA Corporation Device 1c8d (rev a1)
02:00.0 SD Host controller: O2 Micro, Inc. Device 8621 (rev 01)
03:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8821AE 802.11ac PCIe Wireless Network Adapter
04:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 10)
05:00.0 Non-Volatile memory controller: Samsung Electronics Co Ltd Device a804
  • I had similar problems and fixed by following this answer: askubuntu.com/a/543765/421047. Change the driver name in this answer by yours (rtl8821ae). – Gobinath Jan 6 '18 at 14:51
  • I did this and it appears to be working now. Thanks a bunch! – Geirlock Jan 6 '18 at 16:49
0

I had exact problems and I came to know it was something to do with the Power Management in Wireless NIC that was turned ON. Every time the signal power of the Wifi ( to which my device was conneted to ) dropped, device just disconnected from the Network.

So, To turn off the Power Management, first check output of iwconfig command.

$ iwconfig

enp7s0    no wireless extensions.

lo        no wireless extensions.

wlp6s0    IEEE 802.11abgn  ESSID:"Avni.LoveLace"  
          Mode:Managed  Frequency:2.442 GHz  Access Point: C8:D7:79:A1:CE:E4   
          Bit Rate=72.2 Mb/s   Tx-Power=22 dBm   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Power Management:on
          Link Quality=61/70  Signal level=-49 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:722   Missed beacon:0

See If Power Management:on, then turn it off by typing

$ iwconfig wlp6s0 power off

where wlp6s0 is the wireless interface.

It sometimes works sometimes not. If this doesn't helps you, you need to change the Network Configurations for Power Management.

  1. Editing powersave values in /etc/NetworkManager/conf.d/default-wifi-powersave-on.conf

    Possible values of powersave are :

    NM_SETTING_WIRELESS_POWERSAVE_DEFAULT (0): use the default value
    NM_SETTING_WIRELESS_POWERSAVE_IGNORE (1): don't touch existing setting
    NM_SETTING_WIRELESS_POWERSAVE_DISABLE (2): disable powersave
    NM_SETTING_WIRELESS_POWERSAVE_ENABLE (3): enable powersave
    

    Open the file and edit powersave value from whatever it is to 2. That will disable the powersave. By default there is

    wifi.powersave = 3
    

    Just change it to a value of 2.

    wifi.powersave = 2
    

    Save it and Reboot the System and you're done !

  2. Creating Blacklist file for Wireless Power Management

It is well explained by @sagarchalise 's answer on the topic

I think one of these method should work for you, If it's something wrong with Wireless Power Management. If not, then feel free to edit to add more stuff into it.

  • Thanks. But i tried gobinaths suggestion and it worked. And the power management is off now too. – Geirlock Jan 6 '18 at 16:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.