Today the updater asked to install updates, I said yes but the update never finished.

When I tried to install something else I found I couldn't and tried running the command: "sudo dpkg --configure -a" as instructed but the terminal does nothing. Here is the terminal output after running the above command:

sudo dpkg --configure -a
linux-image-4.13.0-21-generic (4.13.0-21.24) wird eingerichtet ...
Running depmod.
update-initramfs: deferring update (hook will be called later)
The link /initrd.img is a dangling linkto /boot/initrd.img-4.13.0-21-generic
) points to /boot/vmlinuz-4.13.0-21-generic
 (/boot/vmlinuz-4.13.0-21-generic) -- doing nothing at /var/lib/dpkg/info/linux-image-4.13.0-21-generic.postinst line 491.
Examining /etc/kernel/postinst.d.
run-parts: executing /etc/kernel/postinst.d/apt-auto-removal 4.13.0-21-generic /boot/vmlinuz-4.13.0-21-generic
run-parts: executing /etc/kernel/postinst.d/dkms 4.13.0-21-generic /boot/vmlinuz-4.13.0-21-generic

It's beens stuck on "run-parts: executing /etc/kernel/postinst.d/dkms 4.13.0-21-generic /boot/vmlinuz-4.13.0-21-generic" for several hours now.

What can I do to fix this? Do I have to install ubuntu again?

1 Answer 1


Same here. Workaround I've found is to uninstall all nvidia drivers - go back to using Nouvo drivers - then reinstall/uninstall kernels and reinstall nvidia drivers. Tedious as it is I can't find any better way to solve it.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .