0

I was working with virtualbox on ubuntu 14.04 suddenly it closed and didn't start afterward. when I tried to load it from terminal it showed me LibQtCore.so.4 file too short, which I've fixed it by reinstalling all needed libraries.

but after rebuilding libraries when I try to open virtualbox from terminal I get :

Segmentation fault (core dumped)

And there is no clue what should I do to fix this. Also my vlc and clementine players has the same status.

what should I do to fix this?

  • Just to be sure, do a memtest to see if your RAM is failing. – fkraiem Jan 6 '18 at 5:23
  • @fkraiem sure i will, but i don't it's ram problem. I have 32 gig ram. and never had a problem with it. – Mohammad_Hosseini Jan 6 '18 at 5:24
  • Have you tried purging and reinstalling VirtualBox? – NerdOfCode Jan 6 '18 at 5:50
  • @NerdOfCode I've just tried, I removed it entirly and result was the same. – Mohammad_Hosseini Jan 6 '18 at 5:56
  • @fkraiem I've done memetest and there was nothing wrong. – Mohammad_Hosseini Jan 6 '18 at 6:05
1

I have had similar issues with virtualbox myself.

I was running on the latest virtualbox 5.2.6 on my ubuntu 16.04.

I did a purge and autoremove all of its libraries+virtualbox.

Installed previous stable version - 5.1.32 and its extensions.

Everything worked fine ever since.

Try to run these commands:

sudo apt-get update
sudo apt-get install -f
sudo apt-get purge virtualbox-5.2.x
sudo apt-get autoremove
sudo apt-get install virtualbox-5.1

if you can't install it from commandline then go to their website: https://www.virtualbox.org/wiki/Downloads

Download the 5.1.32 for ubuntu 14.04/16.04 install the .deb file package by:

sudo dpkg -i virtualbox-5.1_5.1.32-120294_Ubuntu_xenial_amd64.deb

Let us know how it goes.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.