When I open Steam nothing happens but running steam from the terminal it shows

Repairing installation, linking /home/username/.steam/steam to /home/username/.local/share/Steam
Running Steam on ubuntu 17.10 64-bit
STEAM_RUNTIME is enabled automatically
Installing breakpad exception handler for appid(steam)/version(0)
/home/username/.local/share/Steam/ubuntu12_32/steam: symbol lookup error: /usr/lib/i386-linux-gnu/libxcb-dri3.so.0: undefined symbol: xcb_send_request_with_fds
/home/username/.local/share/Steam/steam.sh: Line 444: no match: ssfn*
  • Before anything else make sure your system is fully updated: Run sudo apt update followed by sudo apt full-upgrade. Also edit and update your question accordingly with any error messages and/or new or additional informations. – user692175 Jan 6 '18 at 3:51
  • Might be a locale issue, try setting LC_ALL=C before running steam. i.e. LC_ALL=C steam – Kong Chun Ho Jan 6 '18 at 9:01
  • 2
    Possible duplicate of Steam doesn open on ubuntu 17.10 – ph0t0nix Jan 23 '18 at 13:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.