2

Today, I upgraded from kubuntu 16.10 to 17.04 and then to 17.10, including the required reboots. Before the upgrade I was able to use my printer/scanner SCX-3200 without problems, with 17.10 I can only use the printer part.

sane-find-scanner finds the scanner

$ sane-find-scanner -q
[...]
product=0x3441 [SCX-3200 Series]) at libusb:003:019
[...]

And when I start scanimage the first time, it can talk to the scanner just fine:

$ export SANE_DEBUG_XEROX_MFP=255
$ scanimage -L                                                                                                                                                                                                                   
[sanei_debug] Setting debug level of xerox_mfp to 255.
[xerox_mfp] sane_init: Xerox backend (build 13), version != null, authorize != null
[xerox_mfp] sane_xerox_mfp_get_devices: 0x7ffdf4d2e220, 0
[xerox_mfp] list_one_device: libusb:003:018
[xerox_mfp] usb_dev_open: open 0x55d2e393c5d0
[xerox_mfp] :: dev_command(INQUIRY[0x12], 70)
[xerox_mfp] [70] a8 00 43 10 53 61 6d 73 75 6e 67 20 53 61 6d 73 75 6e 67 20 53 43 58 2d 33 32 30 30 20 53 65 72 69 65 73 20 19 33 84 2b 00 00 27 d8 00 00 36 d8 00 01 51 00 00 01 00 00 00 00 36 d8 00 00 36 d8 00 01 05 05 00...
[xerox_mfp] dev_inquiry: found Samsung/Samsung SCX-3200 Series
[xerox_mfp] usb_dev_close: closing dev 0x55d2e393c5d0
device `xerox_mfp:libusb:003:018' is a Samsung Samsung SCX-3200 Series multi-function peripheral

When I start scanimage a second time it cannot talk to the scanner anymore:

$ scanimage -L
[sanei_debug] Setting debug level of xerox_mfp to 255.
[xerox_mfp] sane_init: Xerox backend (build 13), version != null, authorize != null
[xerox_mfp] sane_xerox_mfp_get_devices: 0x7ffe9ae18760, 0
[xerox_mfp] list_one_device: libusb:003:018
[xerox_mfp] usb_dev_open: open 0x56138cfa1870
[xerox_mfp] :: dev_command(INQUIRY[0x12], 70)
[xerox_mfp] usb_dev_request: sanei_usb_read_bulk: Error during device I/O
[xerox_mfp] dev_command: dev_request: Error during device I/O
[xerox_mfp] usb_dev_close: closing dev 0x56138cfa1870
[xerox_mfp] list_one_device: dev_inquiry(libusb:003:018): Error during device I/O

Unplugging the usb cable and plugging it back in allows scanimage to talk to the scanner once. After that it fails again. The USB cable is not a problem, as it worked with 16.10.

I downloaded VueScan and it has not problems to repeatedly scan pages using the same hw, which also indicates that this is a sw and not a hw problem. And just to mention it again, printing also works fine using the same cable. And yes, I tried multiple USB ports. All exhibit the same behaviour. When I execute scanimage -L once and start VueScan afterwards, then VueScan also doesn't see the scanner anymore. After unplugging and replugging the UBS cable and restarting VueScan, it's able to scan again.

Looks to me like sane doesn't know how to talk to the scanner anymore. It seems that something get's messed up during the first usb command, which prevents subsequent usb commands from succeeding.

I just downloaded 16.04.3 LTS and booted it from a USB stick. I can confirm that the scanner still works with 16.04.

1
  • well Guenther this is a very excellent report; confirming what many suspected; that some "improvement" in 17.10 stops scanning working; please report it to Ubuntu as a bug; we do hope that 18.04; due in April; as an LTS version; has all this explored and fixed; thanks for exploring this topic so well – pdc Jan 6 '18 at 19:39
3

Try

SANE_USB_WORKAROUND=1 xsane

http://www.sane-project.org/ says:

2017-05-22: SANE-Backends-1.0.27

[...]

Note 3: The Linux USB3 workaround which was added in version 1.0.25 is now disabled by default. If you have difficulty using a scanner which previously worked, or intermittent scanner availability, try setting the new environment variable SANE_USB_WORKAROUND=1 before starting your frontend.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.