0

Since I switched to Ubuntu, I have been having tons of problems. This is only one of them.

The software manager seems to be unable to install deb files; For example, I have tried to install MegaSync from its .deb file, but when I click install, it looks like if it began loading and then the install button appears again as if it wasn't touched. Here's a GIF of what I'm talking about:

GIF

Doesn't even ask for my password, and of course, the software doesn't install. It's strange, because I could install Opera using a .deb file before.

Things I have tried;

  • To run sudo apt update in the terminal
  • Restart device

Any ideas?

EDIT: After another restart, I could install some apps; However, I am still unable to open/launch MEGASync.

EDIT 2: This is not a duplicate; Megasync is not the only not working deb, I am having some others that are not working, such as Gdebi and WPS Office.

  • 1
    Possible duplicate of How do I install the Mega Sync Client – Gunnar Hjalmarsson Jan 6 '18 at 0:07
  • 1
    @GunnarHjalmarsson I don't think this is a duplicate of "How do I install the Mega Sync Client", since some other programs such as WPS Office and gdebi aren't working neither – Jesús Jan 6 '18 at 0:12
  • Possibly. But then you have messed up the package system somehow, and need help to fix that. To start with, can you please open a terminal window, run sudo apt update && sudo apt upgrade and let us know the complete output by editing your question. – Gunnar Hjalmarsson Jan 6 '18 at 0:22
  • Alright, this is what I get: i.imgur.com/hx6MYfx.png – Jesús Jan 6 '18 at 0:30
  • It's better to copy the output and paste it into the question. Anyway, the error message in the end might be a result of the failed installation attempt. So can you please run sudo apt purge megasync and then run sudo apt upgrade again to see if the error is gone. – Gunnar Hjalmarsson Jan 6 '18 at 0:36
3
  1. The error message in your comment says that dpkg was interrupted. First you must run the command sudo dpkg --configure -a in the terminal to correct this problem.

  2. You mistakenly downloaded megasync-xUbuntu_16.10_amd64.deb, however you are using Ubuntu 16.04, not 16.10, so download megasync-xUbuntu_16.04_amd64.deb for Ubuntu 16.04 instead.

  3. Then try to install the MegaSync .deb file again by changing to the directory that contains the Megasync .deb file that you downloaded (megasync-xUbuntu_16.04_amd64.deb) with cd and running this command:

    sudo apt install ./megasync-xUbuntu_16.04_amd64.deb  
    

    The advantage of this command over sudo dpkg -i megasync-xUbuntu_16.04_amd64.deb is that it automatically installs the package's dependencies along with the package.

  • Yes, those steps fixed everything. Thank you a lot to everyone! I am very happy with the support you provided. – Jesús Jan 6 '18 at 0:53
-1

I experienced a similar issue and i was able to figure out the next step by entering a terminal and doing the installation manually with dpkg:

cd /home/user/dir/with/package/
sudo dpkg -i package.deb

In most cases i would recommend to use the package provided from the repositories or use an PPA to avoid this kind of conflice and any further conflicts it may cause.

  • Well, it seems like it did install the software, however, I am unable to open it... I already allowed executing the file as program, but still doesn't launch – Jesús Jan 5 '18 at 23:59
  • How do you execute it and what is the result? Is there an error message in the terminal? Did you try "dpkg --listfiles package.deb" to see where it did install its files? – noreabu Jan 6 '18 at 0:01
  • When running the first command you sent, the following appeared in the terminal: i.imgur.com/y8bAWoN.png And when I ran the last command, I got the following: i.imgur.com/VHihaKD.png And also, I am now having the same issue with other apps like WPS Office – Jesús Jan 6 '18 at 0:09
  • @Jesús: It looks like you downloaded the wrong .deb file. I understand that you are on Ubuntu 16.04, and hence it's the .deb for 16.04 - for your architecture (32 or 64 bit) - you should download and install. – Gunnar Hjalmarsson Jan 6 '18 at 0:15
  • 1
    Most of the time, questions stay here to help out future visitors. You could add the solution to the original question and upvote if the answer did help you... – noreabu Jan 6 '18 at 0:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.