I try to establish a wifi connection with my router, however, it does not work, no matter what I try.

iwconfig gives:

lo no wireless extensions. wlan0 IEEE 802.11 ESSID:"A1A0"
Mode:Managed Access Point: Not-Associated Tx-Power=20 dBm
Retry short limit:7 RTS thr=2347 B Fragment thr:off Power Management:off enp7s0 no wireless extensions.

I also tried to restart the network manager with sudo service network-manager stop and then sudo service network-manager start. It did not help either.

I also stopped the network manager and tried:

sudo iwconfig wlan0 essid $SSIDand sudo dhclient -v wlan0. It did not work that way.

lshw -C network gives: *-network Beschreibung: Kabellose Verbindung Produkt: RTL8723BE PCIe Wireless Network Adapter Hersteller: Realtek Semiconductor Co., Ltd. Konfiguration: broadcast=yes driver=rtl8723be driverversion=4.10.0-42-generic firmware=N/A latency=0 link=no multicast=yes wireless=IEEE 802.11, so the driver is from Realtek (rtl8723be).

I also tried sudo apt-get install --reinstall bcmwl-kernel-source. No success.

Has anybody an idea, what I can try to wireless connect to my router?

Thank you in advance!!


Make sure that you have the security settings correct. Unless you have the WPA2 password set, the wireless will never associate.

Ubuntu Server - How to connect to wireless WPA2 personal network? has further instruction.

|improve this answer|||||

Maybe you use Vrtual Machine? I had the same problem when I was using Ubuntu in VMWare Player and when I installed Ubuntu GNU/Linux 16.04 lts as base system, problem solved...

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.