2

I have searched everywhere for solutions for this issue, but now I give up and ask you guru's. My issue is that the brightness of the screen of my Lenovo Thinkpad X1 Yoga 1st gen suddenly started to automatically change to a very low setting. The Yoga has an Intel GPU. I can change the brightness by using Fn+F6, and the brightness goes up. But after only a couple of seconds the screen dims again. Also, if I use the Fn+F6 to increase the brightness there is written an error to the syslog saying:

Jan 5 18:16:27 runmil-ubuntugnome gnome-shell[2892]: percentage lengths not currently supported

I have installed brightness control, that doesn't work at all. I have also installed indicator-brightness, and then the errors on percentage doesn't show anymore, but it still automatically dims the screen. Here is a snippet from the logs:

Jan  5 17:58:53 runmil-ubuntugnome pkexec[18418]: gdm: Executing command [USER=root] [TTY=unknown] [CWD=/var/lib/gdm3] [COMMAND=/usr/lib/gnome-settings-daemon/gsd-backlight-helper --set-brightness 25]
Jan  5 17:59:04 runmil-ubuntugnome pkexec: pam_unix(polkit-1:session): session opened for user root by (uid=1000)
Jan  5 17:59:04 runmil-ubuntugnome pkexec[18437]: runmil: Executing command [USER=root] [TTY=unknown] [CWD=/home/runmil] [COMMAND=/usr/lib/gnome-settings-daemon/gsd-backlight-helper --get-brightness]
Jan  5 17:59:04 runmil-ubuntugnome pkexec: pam_unix(polkit-1:session): session opened for user root by (uid=1000)
Jan  5 17:59:04 runmil-ubuntugnome pkexec[18440]: runmil: Executing command [USER=root] [TTY=unknown] [CWD=/home/runmil] [COMMAND=/usr/lib/gnome-settings-daemon/gsd-backlight-helper --set-brightness 56]
Jan  5 17:59:04 runmil-ubuntugnome pkexec: pam_unix(polkit-1:session): session opened for user root by (uid=1000)
Jan  5 17:59:04 runmil-ubuntugnome pkexec[18444]: runmil: Executing command [USER=root] [TTY=unknown] [CWD=/home/runmil] [COMMAND=/usr/lib/gnome-settings-daemon/gsd-backlight-helper --get-brightness]
Jan  5 17:59:05 runmil-ubuntugnome pkexec: pam_unix(polkit-1:session): session opened for user root by (uid=1000)
Jan  5 17:59:05 runmil-ubuntugnome pkexec[18454]: runmil: Executing command [USER=root] [TTY=unknown] [CWD=/home/runmil] [COMMAND=/usr/lib/gnome-settings-daemon/gsd-backlight-helper --get-brightness]
Jan  5 17:59:05 runmil-ubuntugnome pkexec: pam_unix(polkit-1:session): session opened for user root by (uid=1000)
Jan  5 17:59:05 runmil-ubuntugnome pkexec[18457]: runmil: Executing command [USER=root] [TTY=unknown] [CWD=/home/runmil] [COMMAND=/usr/lib/gnome-settings-daemon/gsd-backlight-helper --set-brightness 112]
Jan  5 17:59:05 runmil-ubuntugnome pkexec: pam_unix(polkit-1:session): session opened for user root by (uid=1000)
Jan  5 17:59:05 runmil-ubuntugnome pkexec[18461]: runmil: Executing command [USER=root] [TTY=unknown] [CWD=/home/runmil] [COMMAND=/usr/lib/gnome-settings-daemon/gsd-backlight-helper --get-brightness]
Jan  5 17:59:05 runmil-ubuntugnome pkexec: pam_unix(polkit-1:session): session opened for user root by (uid=1000)
Jan  5 17:59:05 runmil-ubuntugnome pkexec[18467]: runmil: Executing command [USER=root] [TTY=unknown] [CWD=/home/runmil] [COMMAND=/usr/lib/gnome-settings-daemon/gsd-backlight-helper --get-brightness]
Jan  5 17:59:05 runmil-ubuntugnome pkexec: pam_unix(polkit-1:session): session opened for user root by (uid=1000)
Jan  5 17:59:05 runmil-ubuntugnome pkexec[18470]: runmil: Executing command [USER=root] [TTY=unknown] [CWD=/home/runmil] [COMMAND=/usr/lib/gnome-settings-daemon/gsd-backlight-helper --set-brightness 168]
Jan  5 17:59:05 runmil-ubuntugnome pkexec: pam_unix(polkit-1:session): session opened for user root by (uid=1000)
Jan  5 17:59:05 runmil-ubuntugnome pkexec[18474]: runmil: Executing command [USER=root] [TTY=unknown] [CWD=/home/runmil] [COMMAND=/usr/lib/gnome-settings-daemon/gsd-backlight-helper --get-brightness]
Jan  5 17:59:06 runmil-ubuntugnome pkexec: pam_unix(polkit-1:session): session opened for user root by (uid=121)
Jan  5 17:59:06 runmil-ubuntugnome pkexec[18479]: gdm: Executing command [USER=root] [TTY=unknown] [CWD=/var/lib/gdm3] [COMMAND=/usr/lib/gnome-settings-daemon/gsd-backlight-helper --set-brightness 34]
Jan  5 17:59:07 runmil-ubuntugnome pkexec: pam_unix(polkit-1:session): session opened for user root by (uid=121)
Jan  5 17:59:07 runmil-ubuntugnome pkexec[18484]: gdm: Executing command [USER=root] [TTY=unknown] [CWD=/var/lib/gdm3] [COMMAND=/usr/lib/gnome-settings-daemon/gsd-backlight-helper --set-brightness 34]
Jan  5 17:59:37 runmil-ubuntugnome pkexec: pam_unix(polkit-1:session): session opened for user root by (uid=121)
Jan  5 17:59:37 runmil-ubuntugnome pkexec[18505]: gdm: Executing command [USER=root] [TTY=unknown] [CWD=/var/lib/gdm3] [COMMAND=/usr/lib/gnome-settings-daemon/gsd-backlight-helper --set-brightness 25]
Jan  5 17:59:39 runmil-ubuntugnome pkexec: pam_unix(polkit-1:session): session opened for user root by (uid=121)
Jan  5 17:59:39 runmil-ubuntugnome pkexec[18510]: gdm: Executing command [USER=root] [TTY=unknown] [CWD=/var/lib/gdm3] [COMMAND=/usr/lib/gnome-settings-daemon/gsd-backlight-helper --set-brightness 25]
Jan  5 17:59:42 runmil-ubuntugnome pkexec: pam_unix(polkit-1:session): session opened for user root by (uid=121)
Jan  5 17:59:42 runmil-ubuntugnome pkexec[18519]: gdm: Executing command [USER=root] [TTY=unknown] [CWD=/var/lib/gdm3] [COMMAND=/usr/lib/gnome-settings-daemon/gsd-backlight-helper --set-brightness 25]
Jan  5 17:59:42 runmil-ubuntugnome pkexec: pam_unix(polkit-1:session): session opened for user root by (uid=121)
Jan  5 17:59:42 runmil-ubuntugnome pkexec[18524]: gdm: Executing command [USER=root] [TTY=unknown] [CWD=/var/lib/gdm3] [COMMAND=/usr/lib/gnome-settings-daemon/gsd-backlight-helper --set-brightness 25]
Jan  5 17:59:45 runmil-ubuntugnome pkexec: pam_unix(polkit-1:session): session opened for user root by (uid=121)
Jan  5 17:59:45 runmil-ubuntugnome pkexec[18529]: gdm: Executing command [USER=root] [TTY=unknown] [CWD=/var/lib/gdm3] [COMMAND=/usr/lib/gnome-settings-daemon/gsd-backlight-helper --set-brightness 25]

As you can see, gdm is running a command to change the brightness every now and then, setting it to 25 or 34 out of 852. Then I update it using indicator-brightness-adjust --up, and it goes up to first 56, then 112 and finally 168. But only 1 second later gdm is automatically changing the brightness to 34 again.

I am running a completely updated Ubuntu 17.10, using Gnome and Wayland.

I understand I might have installed something that has messed this up, but I can't find out what. It works without issues with external monitor. No difference on battery or power. I have tried with lots of different grub-settings, but nonw of them have worked. I have tlp running, can't find anything there regarding this error.

I have been running Ubuntu 17.10 since october, and it worked well until mid-december. I don't really know exactly when, 80% of that time I have an external monitor attached.

So, does any of you gurus have any idea on how to troubleshoot this?

  • I just found some new evidence. The brightness this morning was good, but not now. Something is changing the brightness based on either surrounding light or time of day. I have disabled both night light and the ambient light sensor (ALS). Do anyone know what this might be? – Rune Jan 6 '18 at 17:08
  • So it is something regarding automatic brightness. If I point a torch to the computer the brightness goes up. But it is quite annoying to need a headlamp to be able to use the computer... :-) I have disabled automatic brightness under power settings. If I enable it the screen blinks from 0 brightness to 500 every 10th second or so. – Rune Jan 8 '18 at 19:02
  • I have a related but opposite issue: askubuntu.com/questions/1009033/… – joar Feb 23 '18 at 12:43
  • I think I have found something, and I use it as a workaround for my own problems. While on the logon screen I can change the brightness. The brightness I set on the logon screen is what will be set as "default" after logging in. So I set it to something that is OK, approx 60% or so, and that is what it will change to whenever I try to change brightness. But I get an OK brightness either way. @Joar, can you try to perform this task to verify we have the same issue? – Rune Feb 25 '18 at 15:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.