41

The latest updates (4/1/2018) make my laptop constantly crash the GUI/Unity:

(Intel Pentium su4100 processor)

syslog:

Jan  5 11:38:53 1810 kernel: [ 1850.327738] compiz[11911]: segfault at 0 ip 00007f6c7baf0c16 sp 00007ffd5ec71c60 error 4 in i965_dri.so[7f6c7b513000+82d000]

After login I end up with an empty desktop, just a wallpaper, GUI/Unity are in a crash loop:

  • No panel.
  • No dash.
  • Can't start a program.
  • Launcher disappears.
  • Sidebar disappears.
  • System crash.
  • Windows key not working.
  • The key combination Alt+Tab not working.

Simply, the computer is not usable. Same for guest login. The only thing working: open up a terminal CTRL+ALT+T to examine log files.

I somehow forced Low Graphics Mode on Unity to let me log in and file the bug, but still lots of problems:

  • Dash not working
  • Alt+Tab not working
  • Sometimes windows all disappear for a few seconds

Bug report

Any ideas for a solution or workaround?

UPDATE

If you have the same/ very similar problems, follow the link to my bug report and mark there that you're affected too. Or file your own. Please leave a comment if you wish, or upvote - this is a nasty problem - but an answer should offer a fix or a workaround so users can use their computer again.

Without proper bug reports, Ubuntu can't fix issues.

  • 2
    Please consider title change to something like After Ubuntu 16.04 January 2018 update, Launcher / Sidebar disappears, system crash similar to many questions already posted here. That way average user is more likely to find this Q&Ain search. Many don't know what a memory segment fault is. – WinEunuuchs2Unix Jan 9 '18 at 0:52
  • 1
    This is by far the worst update bug I experienced in 11 years. It's always difficult to find the right balance in wording for both noobs and nerds. I choose compiz segfaults because that's the message in the syslog (/var/log/syslog). – Janghou Jan 9 '18 at 9:32
  • 2
    You'll now want to mark yourself as affected by the other bug that @janghou's was marked a duplicate of. Also please don't leave pointless comments (e.g. explaining a workaround that hasn't been mentioned yet is fine, 'me too OMG this is so terrible devs what the heck are you doing?!??!' is not fine and will just clutter dev inboxes and make them annoyed) – Ads20000 Jan 10 '18 at 10:08
31

UPDATE APRIL

I was hit again by this bug/symptoms on 26 April 2018. I could solve it by applying the March fix AND additionally cleaning the crash dir.

rm ~/.config/upstart/lowgfx.conf
sed -i 's/-lowgfx//' ~/.config/compiz-1/compizconfig/config
rm -r ~/.cache/
sudo rm -r /var/crash/*
reboot

UPDATE March 2018.

It seems a bug with more or less the same symptoms hit a couple of users beginning of March 2018. This new bug is in compiz-config, not compiz. And it is less severe: guest session and low graphics mode is working fine. New bug report.

Fix (for most users):

rm ~/.config/upstart/lowgfx.conf
sed -i 's/-lowgfx//' ~/.config/compiz-1/compizconfig/config
rm -r ~/.cache/
reboot

Explanation: Remove any lowgfx.conf file and change profile = unity-lowgfx to profile = unity in .config/compiz-1/compizconfig/config. Clean the .cache directory in your home directory.Reboot.Thx to everyone contributing in the bugreport.

If you're hit in March and above solution is not working, leave a message on the bug report. Try workaround 3 (see below). Otherwise try to tweak compiz settings in CCSM. Or delete/clean your ~/.cache directory.


Bug Fixed (January)

This bug is fixed now. Updates are in Xenial-updates, so an update will solve the issue.

 sudo apt update && sudo apt upgrade -y

You can disable proposed:

 System Settings -> Software & Updates -> Tab Developer options -> uncheck proposed

Or revert any of your workarounds.

Background

This bug is acknowledged and caused by the mesa updates of 2018-01-04 to 17.2.4. The bug is now marked as a duplicate of an earlier bug filed 2017-12-01, unfortunately that bug was misfiled.

Only older Intel, ~2006-2011, with integrated graphics (gen4/5) are affected, so that's why it slipped through testing. And it only seems to affect Unity, not Gnome or LXDE.

Following info is obsolete

The patch for this bug will be available in xenial-proposed shortly. Please help Ubuntu by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Please give feedback at the bug report page to help getting this update out to other Ubuntu users. See comment 48 for info.

To enable proposed (please read info in above links first):

 System Settings -> Software & Updates -> Tab Developer options -> check proposed

Install patches

  sudo apt-get install libgl1-mesa-dri/xenial-proposed
  sudo reboot

Then add a file /etc/apt/preferences.d/proposed-updates

 Package: *
 Pin: release a=xenial-proposed
 Pin-Priority: 400

This will protect you from updating all packages in the proposed repository next time you do a sudo apt upgrade. You don't want that.

If you add this file before you install the patches, you will get a dependency error message.

If you have used a PPA as a workaround, you have to purge that first.

 sudo ppa-purge ppa:paulo-miguel-dias/pkppa
 sudo reboot

Until this bug is fixed, what are the workarounds?

1. Install lubuntu-desktop (LXDE) aside unity

sudo apt-get install lubuntu-desktop

This will take around 400MB and install things like Abiword, you can remove them later to save disk-space. Simply choose Lubuntu at login. Remove lubuntu-desktop again when the bug is resolved.

2. Downgrade the mesa-packages

This is described in the bug report. It can have unwanted side-effects and break dependencies, so decide for yourself.

As it seems these 4 packages need to be downgraded:

libegl1-mesa 17.2.4-0ubuntu1~16.04.2
libgbm1 17.2.4-0ubuntu1~16.04.2
libgl1-mesa-dri 17.2.4-0ubuntu1~16.04.2
libwayland-egl1-mesa 17.2.4-0ubuntu1~16.04.2

One way is to download them from the link in this comment and follow the instructions. dpkg -i *.deb

I you use Wine you will need the i386 packages too.

Prevent automatic upgrading from these 4 packages. Don't forget to remove that file once the bug is resolved.

3. Use low graphics mode

This will mitigate the bugs and give you a somewhat working GUI. But:

  • Dash not working
  • Alt tab not working
  • logout, reboot and halt needs to be done with terminal, same for programs not in the launcher
  • super key (windows) not working

That said: launcher, workspace switching and keyboard shortcuts are working, so just spread your programs over workspaces :)

Create a file ~/.config/upstart/lowgfx.conf

start on starting unity7
pre-start script
initctl set-env -g UNITY_LOW_GFX_MODE=1
end script

Logout and login.

4. PPA

Update mesa to a newer version through a PPA. Don't forget to purge the PPA when the bug is solved. This is probably the best choice. Please read the info on the PPA-page before you apply following code.

 sudo apt-add-repository ppa:paulo-miguel-dias/pkppa
 sudo apt update && sudo apt upgrade -y
 sudo reboot

Reboot and it should be fine. If not please leave a message in the bug report.

Don't forget to purge the PPA when the bug is resolved.

 sudo ppa-purge ppa:paulo-miguel-dias/pkppa

5. Downgrade from HWE to stock kernel (and mesa/x-server)

Bug is caused by mesa (17.2.4) updates, and mesa is updated along kernels in the HWE stack. Returning to stock kernel (4.4) will solve the issue, it will downgrade mesa to 11.2.

sudo apt install --install-recommends xserver-xorg xserver-xorg-core
xserver-xorg-video-all xserver-xorg-input-all xserver-xorg-video-intel 
server-xorg-video-qxl
sudo reboot

That will removes all HWE packages. Probably the most secure solution.

Hopefully this bug bug will be solved soon. Consider helping Ubuntu in testing .

  • If you have free 1Gb - the ubuntu-mate-desktop may be good alternative too, I think. – N0rbert Jan 8 '18 at 14:30
  • 1
    Can confirm bug is not on Skylake i7 6700HQ 6th generation CPU with HD 530 graphics. I'm going to boot my 3rd generation i7 3630QM laptop with HD4000 graphics and change Update policy from every 2 weeks to NEVER until bug is solved. Thanks for the valuable information. – WinEunuuchs2Unix Jan 9 '18 at 0:32
  • 1
    Applying the proposed update worked. For now everything seems to work like it should. Thanks a lot! – E.F. Nijboer Jan 13 '18 at 22:34
  • 1
    Thank you for the March 2018 update. – Mike S Mar 28 '18 at 19:15
  • 1
    @Howard. What about upgrading? Went to 18.04 and haven't had the problem since. BTW I dropped Gnome 3 and choose Mate, better suited for older hardware IMHO. I guess I will choose Lubuntu when LXQt is there. – Janghou Jul 25 '18 at 9:50
0

This recently affected me on 17.10 (i7-6700K, Intel HD530). I upgraded to the MESA PPA suggested here which didn't fix the issue, but by manually going through my compiz plugins in CCSM, it seems that the Grid plugin was specifically the one causing issues for me.

Disabling Grid works for me; enabling grid but turning off all the preview settings in the Appearance tab seems to also be working so far (I really don't want to lose Grid's functionality if I can avoid it).

Absolutely the worst bug I've ever experienced on Ubuntu :(

  • 1
    Perhaps a screen shot or two will help other users navigate changing their configuration. Also I think most users don't have Compiz Tweak Tool or whatever it is called and still are effected by the bugs. – WinEunuuchs2Unix Mar 27 '18 at 1:19
0

For me it helped to disable the D-Bus plugin. This is a workaround only though, as I would like to use it.

Reference: Bug #1641944 on Launchpad

protected by Community Jan 6 '18 at 9:10

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.