I am using Ubuntu 16.04, running this command succeeded:

sudo snap install spotify

And running it again indicates Spotify is installed. However, running:


Gives command not found! Searching in Unity for "spotify" yields no results. What can I do?

  • 3
    Try /snap/bin/spotify to launch it. You might not have the /snap/bin in your path.
    – Terrance
    Jan 5, 2018 at 3:46
  • That exists and runs, but nothing happens afterwards.
    – user126350
    Jan 5, 2018 at 4:03

7 Answers 7


Check your $PATH variable by executing in a Terminal:

echo $PATH

The output should be very similar to this:


You have to verify if /snap/bin is included in this $PATH, otherwise you have to add it manually, here is how to do it: How do I modify my PATH so that the changes are available in every Terminal session.

If this doesn't work, try deleting and installing again the snap, the required commands are:

  • Execute sudo snap list to verify if Spotify is installed.

  • Use sudo snap remove spotify to delete it.

  • Use sudo snap install spotify to re-install it again.

After installing it you can run the command which spotify to see if it is recognized now.

Hope it helps, good luck!

  • Thank you! I was going to mention to OP to add /snap/bin to the path as I just tested out spotify and it worked fine. +1 =)
    – Terrance
    Jan 5, 2018 at 4:07
  • Thanks just reinstalled after augmenting the path and it seems to be working now (although takes a solid 15 seconds to load).
    – user126350
    Jan 5, 2018 at 4:12
  • @user126350 Yep, that is one thing I noticed is that it was slow to come up.
    – Terrance
    Jan 5, 2018 at 4:13
  • You're welcome to both of you, glad to hear that! :D
    – galoget
    Jan 5, 2018 at 4:13

The solution is simple. Log out and log back in again.

Same thing happened to me. It was the first time I had installed a snap app, and I expect that the $PATH variable had changed as per other answers, but the change only takes effect after logging out and logging back in again.


Personally, I simply had to open a different Terminal window. For some reason it couldn't find it from the window I'd used to run the snap command.

  • 3
    source ~/.profile should have the same effect if you don't want to open a new terminal.
    – Bprodz
    Aug 13, 2018 at 11:33
  • @Bprodz , yours is the right answer. Please consider posting it as an answer so I can upvote it. Let me know when you do.
    – evaristegd
    Apr 20, 2020 at 1:57

Another solution is go to the folder /snap/spotify/6/usr/bin/ and double-click the file spotify.

This worked to me.


I've added to the menu using alacarte, then adding /snap/bin/spotify to the music section


On debian 9, I had to add /snap/bin to the root PATH manually. Do the following:

In /etc/login.defs, you will find the following line:

ENV_SUPATH PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin

Add the path so that it will be:

ENV_SUPATH PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/snap/bin

Exit the session, and login again.


I'm on elementary OS FWIW. My paths are correct.

I was able to manually launch the item via @Zzzach...'s answer subbing in the symlink "current" for the version number as his answer must have been early on in the snap spotify install.

So I manually edited the desktop entry at:


To change the exec location from:



/snap/spotify/current/usr/bin/spotify %U

and then it worked via snap. Whether it persists across an update is another story.

I think you could also edit this via the alacarte option too.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.