4

Right now on Opera with my Ubuntu 14.04 it says it is version 45.0.2552.898.

Then it says

Browser upgrade required

VPN is unsupported on your current version of Opera. Please upgrade to the newset version of Opera to continue using the VPN service.

However, in About Opera, it also says

45.0.2552.898 - Opera is up to date

I've tried removing and installing via apt-get again but it get

Setting up opera-stable (45.0.2552.898)

I've also tried downloading the DEB and RPM files from opera.com but they also are this same version.

Any ideas what is going on or how to solve it?

  • Possibly a bug / issue with Opera or it's VPN service itself - it seems you do have the latest version,, since the version you have is also available via the Opera website. – JonasCz Jan 4 '18 at 22:00
1

If you are running 14.04 release of 32-bit system, the "About Opera" page will indeed look like this:

Version: 45.0.2552.898 - Opera is up to date

Update stream: Stable

System: Ubuntu 14.04.5 LTS (x86; XFCE)

Most recent discussion dated November 2017, was found as this thread on Opera forums, which gives a direct answer from a moderator.

Nope, support for Linux 32 bits has been ended.

For official information, this dated post "Frequently-asked questions about Opera for Linux" in late December 2014 on Opera blogs that mentioned only 64-bit Opera is provided for recent releases.

Is Opera available for 32-bit Linux?

The latest stable version of Opera for Linux is 64-bit only, based on what most Linux desktop users have installed. However we have developer versions of 32-bit Opera^1.

^1 This link points to another dated post featuring Opera Developer 30 in 2015. Link has been quoted anyway, since the post mentioned the decline usage of 32-bit Linux systems.

The "Browser upgrade required" restriction seems to be added recently. I was still able to use VPN service from Opera for Linux until end of 2017.

Anyway, recent versions of Opera for Linux is for 64-bit systems only.

2

Looks like it is relatively easy to get to the latest stable release of Opera under Ubuntu 14.04 and version 50.0.2762.45 certainly has a working VPN on my system. Add the following PPA and install opera-stable:

sudo sh -c 'echo "deb http://deb.opera.com/opera-stable/ stable non-free" >> /etc/apt/sources.list.d/opera.list' 
wget -O - http://deb.opera.com/archive.key | sudo apt-key add -
sudo apt-get update
sudo apt-get install opera-stable

This worked fine on my Ubuntu 14.04 system as the following screenshot demonstrates:

enter image description here

And another screenshot showing the VPN at work:

enter image description here

References:

  • That's right with this method you can get the 50.0.2762.45 version of Opera Stable and the VPN works fine, I just tried it myself. +1 =) – galoget Jan 5 '18 at 5:19
  • @galoget Newest Opera looks very, very nice... – andrew.46 Jan 5 '18 at 6:47
  • Thanks, I can't check right now but I'll get back to you later. – Michael Jan 5 '18 at 8:49
  • I tried this and it still gave me the blocking message when switching the VPN on. I think your solution will work for 64-bit. I'm still on 32-bit – Michael Jan 5 '18 at 21:08
  • @Michael 32bit support slowly fading away in a lot of areas... – andrew.46 Jan 6 '18 at 5:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.