0

I'm using my phone right now because I completely lost access to my Z510 laptop running 14.04 (Trusty Tahr), I had no problem using my laptop, everything worked fine and I was really enjoying it for a while just before I had this temptation to install the videogame Dota 2 which runs on an independent client known as steam.

This is where the problem actually appears: software runs but asks that the user must install three packages, namely,

libgl1-mesa-dri:i386, libg1-mesa-glx:i386 and libc6

I checked synaptic for these packages, successfully found them and install them, they also automatically removed some other packages under the architecture amd64, I thought to myself that I have a 4th gen i7 CPU, so this kind of changing may be good for performance by what its name has to offer. After installing them (and removing others) I went to Nvidia settings tried to switch to my GF 740m graphic card, I encountered an error, so decided to reboot the machine and here I am, the purple frozen screen.

Can I do something about it? may I somehow acces to my stored data (some of them are pretty necessary)? Can I repair the OS using a live usb/dvd ubuntu image? what do you suggest? Thanks in advance

  • That's tough luck. Can you at least switch to a non-graphic terminal (Ctrl-Alt-F4)? – Gyro Gearloose Jan 4 '18 at 12:33
  • Nah, not in the frozen purple screen, should I try it earlier!? – Ashkan Ranjbar Jan 4 '18 at 12:36
  • fortunately recovery mode is still working, but how does it work? can you help me on doing so? Gyro – Ashkan Ranjbar Jan 4 '18 at 12:41
  • If that doesn't work, things look really bad. You can try the same with F5 to F6, F7 is the port where the graphic is running. If even Ctrl-Alt-Del doesn't work, the system messed up your keyboard. If so, the only hope is to connect remotely, or via BIOS. I'm not an expert in either of those. – Gyro Gearloose Jan 4 '18 at 12:42
  • I don't know about recovery mode, but if it allows you to save your data to some external backup device, do so. – Gyro Gearloose Jan 4 '18 at 12:43
1

i386 is 32-bit, amd64 is 64-bit, it has nothing to do with the CPU manufacturer. You needed to enable multiarch and add the i386 architecture in order to install the 32-bit libraries.

since 32-bit and 64-bit libraries often conflict, you likely removed the 64-bit version of the libraries you installed. Mesa is your graphics library.

try booting in recovery mode and see if you can get a command prompt to reverse the changes you made.

  • Very helpful on the subject of architecture, but I don't know how to revert them, since I used the graphical synaptic, please don't hesitate to see me as a complete noob on the subject – Ashkan Ranjbar Jan 4 '18 at 13:19
  • aptitude is a command line package manager. if it isn't already installed, sudo apt-get istall aptitude will install it – ravery Jan 4 '18 at 13:23
  • does it work for reverting such modifications? – Ashkan Ranjbar Jan 4 '18 at 13:32
  • well there is not "go back" button, but it can be use to reinstall the libraries that were removed. type "/" to get a search bar and search for "mesa" – ravery Jan 4 '18 at 13:38
  • Well that's not a good solution when I don't know which packages I should install and which I should remove. Can I plug my external hard drive into my laptop and move my needed directories (in my case /home, /usr/local/bin/anaconda3 and /usr/local/bin/rapidminer ) and start a fresh install? I just need to know how can I plug/mount/recognize my external drive through the recovery terminal? – Ashkan Ranjbar Jan 4 '18 at 15:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.