1

How can I disable Alt-Tab application switching in Cinnamon when a certain program is open? In System Settings > Keyboard > Shortcuts Tried to disable, click on it to set a new shortcut, then pressing Backspace to set disable that shortcut.

Using gsettings commands The keybindings to switch to another workspace are set in:

org.gnome.desktop.wm.keybindings

gsettings set org.gnome.desktop.wm.keybindings switch-applications []
gsettings set org.gnome.desktop.wm.keybindings switch-applications-background []

I have tried these many methods to disable alt+tab key but still not disabled. Maybe I need to set it globally but in ubuntu where alt+tab key values stored, I don't known. Please help me on this.

2

Try to change it with dconf (from dconf-cli package):

dconf load / << EOF 
[org/compiz]
current-profile='unity'

[org/compiz/profiles/unity/plugins/unityshell]
alt-tab-prev='Disabled'
launcher-switcher-prev='Disabled'
alt-tab-forward='Disabled'
launcher-switcher-forward='Disabled'
alt-tab-forward-all='Disabled'
alt-tab-prev-all='Disabled'

[org/compiz/profiles/unity/plugins/switcher]
prev-all-key='Disabled'
prev-key='Disabled'
next-all-key='Disabled'
next-key='Disabled'

[org/compiz/profiles/unity/plugins/staticswitcher]
prev-all-key='Disabled'
next-all-key='Disabled'

[org/compiz/profiles/unity-lowgfx/plugins/unityshell]
alt-tab-prev='Disabled'
launcher-switcher-prev='Disabled'
alt-tab-forward='Disabled'
launcher-switcher-forward='Disabled'
alt-tab-forward-all='Disabled'
alt-tab-prev-all='Disabled'

[org/compiz/profiles/unity-lowgfx/plugins/switcher]
prev-all-key='Disabled'
prev-key='Disabled'
next-all-key='Disabled'
next-key='Disabled'

[org/compiz/profiles/unity-lowgfx/plugins/staticswitcher]
prev-all-key='Disabled'
next-all-key='Disabled'
EOF

Notes:

  1. this will disable all occurrences of Tab key.
  2. on my VirtualBox 16.04 LTS has two Compiz profiles - unity and unity-lowgfx. If you are sure that you have only unity you can skip unity-lowgfx.

You can revert to default settings with

dconf reset /org/compiz/profiles/unity-lowgfx -f
dconf reset /org/compiz/profiles/unity -f

then logout and login again.

9
  • I tried the above code but still issue remains. Please let me know alternatives ways to do it. – Dinesh Jan 4 '18 at 14:20
  • I updated my answer. It was not too simple. – N0rbert Jan 4 '18 at 20:12
  • Great !! It works fine. – Dinesh Jan 5 '18 at 9:28
  • Do not forget to vote and accept it if it helped :) – N0rbert Jan 5 '18 at 12:31
  • dconf load / << EOF [org/gnome/desktop/wm/keybindings] show-desktop='Disabled' maximize='Disabled' unmaximize='Disabled' EOF. I have tried this. should I try it for unity-lowgfx? Please suggest on this. – Dinesh Jan 9 '18 at 12:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.