I'm using crouton on a Samsung pro 2 Chromebook. I'm currently running GNOME on Xenial. Unless I download via terminal, I get this message:

You are not allowed to perform this action.

And when I expand to see details I get this:

org.freedesktop.PolicyKit.Error.Failed: ('system-bus-name', {'name': ':1.83'}): org.debian.apt.install-or-remove-packages

Any ideas?


3 Answers 3


I take it this is your first time running a Chroot you've installed on your Chromebook? In other words, this is the first time you've encountered this problem, yes?

In short, you'll have to use the gksu, instead of sudo, whenever you require the graphical interface to grant you the permissions you seek. It'll be simple, and it'll be quic--

Until someone more knowledgable than myself graces you with their presence, in the meantime, open up that terminal, and let's get you going with some software installations.

Inside a terminal type the following command:

gksu gnome-software

This will prompt you to enter your password, and then the gnome software store will run, with you having all them sweet, juicy permissiones!

You'll have to run the software store using this command every time you wish to install software from it, otherwise, using "sudo" inside a term to install programs will work as usual.

This won't by any means break your desktop, so you're totally good. It is, however, worth mentioning that there are things one should be aware of when running gksu, but I'll let the next bloak explain that.


On Ubuntu 18.04 I could not find the command gksu, or a way to install it. But this worked for me.

sudo -i gnome-software
  • This worked for me one Ubuntu 18.04
    – Moia
    Commented Dec 11, 2019 at 8:19

On Ubuntu 19.10, we always use sudo apt install mydeb.deb this will prompt us to enter password once password entered then the install operation has always been smooth like we regluarly update using sudo apt-get update.

Try reinstalling software center by using this command sudo apt-get install --reinstall software-center gnome-software and resolve permission issues if there are any by using following command to grant ownership:

sudo chown <user>:<user> /usr/bin/gnome-software

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .