1

i assembled a new PC based on a AM4 Platform. The Mainboard provides a Realtek ALC892 Codec for audio.

Sometimes the sound gets very distorted (crackling noises). Since the last boot the problem is persistent.

I attached my headphones using a 3.5mm cable, when attaching the headphones directly the problem does still exist, so this is not the problem. When i attach the headphones to my android device the sound is perfect, so it has to be related to my setup here.

  • Ubuntu Version is 16.04.3
  • Kernel: 4.10.0-42-generic

I allready checked this related quesion, but that did not work.

The sound is like someone is constantly twisting the cable. It is extremely annoying :-(

UPDATE 2018-02-06:

Did not find any solution so far, the situation is unchanged (kernel @ 4.13.0-32-generic).

I noticed, that the crackling starts about 1 hour after i booted and persists for about 15 minutes. It will not happen multiple times in one work-day - only once. Rebooting helps, but i cant reboot all the time...

UPDATE 2018-03-28:

Very strange: Today the same problem occured on a different machine. This machine has a Creative Soundblaster SB0730 soundcard connected via PCI because the integrated audio is broken. Everything worked perfectly until today - when suddenly the sound began to freak out.

Its a dualboot setup, so i booted into windows to see if the soundcard causes the crackling but windows plays all sounds perfectly.

This problem is really really weird. Both systems are AMD-based, this system is a AM3+ Platform with a AMD FX-8320, Mainboard = ASUS M5A97 LE R2.0.

Same Ubuntu version, same Kernel, so it might be connected...

UPDATE 2018-06-05:

No change, but it seems to happen less often now Kernel: 4.13.0-43-generic

  • I have this now, kernel 4.18, Debian 9. Any success? You mean even a separate sound card didn't help you? – Sergey Jan 18 at 7:29
  • No, i did not find any solution so far. But i did not check for a long time, i currently work on a notebook where that problem does not occur. A strange thing i noticed is, that the crackling sometimes stopped when i killed certain processes (docker, virtualbox, everything related to virtualization). Maybe completely random but who knows... – Philipp Wrann Jan 21 at 15:02
  • The problem happened when an application used mic. Just playback (wihtout mic) was ok. The only thing I came up with was buying a sound card supported in Linux. This will save me from such problems in future. – Sergey Jan 21 at 15:11
0

Are you still having this issue? Supposedly the problem can be fixed by disabling "auto-mute". Use the command alsamixer and ensure your terminal window is widened so the option shows, then navgate to it with the arrow keys. I think up/down disables it. There are some that say this doesn't work though so I'm sorry if it doesn't fix the issue.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.