0

I am having problem on this error "error while loading shared libraries: libz.so.1: " . so I install this package apt-get install zlib1g:i386 but this is th result.

Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 libssl-dev : Depends: libssl1.0.0 (= 1.0.2g-1ubuntu4.8) but 1.0.2g-1ubuntu4.10 is to be installed
              Depends: zlib1g-dev but it is not going to be installed
              Breaks: libssl-dev:i386 (!= 1.0.2g-1ubuntu4.8) but 1.1.0g-2.1+ubuntu16.04.1+deb.sury.org+1 is to be installed
 libssl-dev:i386 : Breaks: libssl-dev (!= 1.1.0g-2.1+ubuntu16.04.1+deb.sury.org+1) but 1.0.2g-1ubuntu4.8 is to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

This is my operating system

Distributor ID: Ubuntu
Description:    Ubuntu 16.04.3 LTS
Release:        16.04
Codename:       xenial

I tried apt-get -f install and this is the result

(Reading database ... 129365 files and directories currently installed.)
Preparing to unpack .../libssl-dev_1.1.0g-2.1+ubuntu16.04.1+deb.sury.org+1_amd64.deb ...
Unpacking libssl-dev:amd64 (1.1.0g-2.1+ubuntu16.04.1+deb.sury.org+1) over (1.0.2g-1ubuntu4.8) ...
dpkg: error processing archive /var/cache/apt/archives/libssl-dev_1.1.0g-2.1+ubuntu16.04.1+deb.sury.org+1_amd64.deb (--unpack):
 trying to overwrite shared '/usr/include/openssl/e_os2.h', which is different from other instances of package libssl-dev:amd64
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Errors were encountered while processing:
 /var/cache/apt/archives/libssl-dev_1.1.0g-2.1+ubuntu16.04.1+deb.sury.org+1_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Thank you in advance.

  • tried this? Try 'apt-get -f install' with no packages ? – hellozee Jan 4 '18 at 7:01
  • 1
    Please update your question with output of apt-cache policy libssl-dev. It seems that you have PPA or other third-party repository enabled. – N0rbert Jan 4 '18 at 10:48
  • +1 . . . specifically this PPA – steeldriver Jan 4 '18 at 13:47
1

Although there is no question posted, I assume you want to move forward with apt-get install zlib1g:i386.

Do sudo apt-get -f install, similar to what was suggested. That should fix your dependency system.

What exactly does sudo apt-get -f install do?

  • dpkg: error processing archive /var/cache/apt/archives/libssl-dev_1.1.0g-2.1+ubuntu16.04.1+deb.sury.org+1_amd64.deb (--unpack): trying to overwrite shared '/usr/include/openssl/e_os2.h', which is different from other instances of package libssl-dev:amd64 dpkg-deb: error: subprocess paste was killed by signal (Broken pipe) Errors were encountered while processing: /var/cache/apt/archives/libssl-dev_1.1.0g-2.1+ubuntu16.04.1+deb.sury.org+1_amd64.deb E: Sub-process /usr/bin/dpkg returned an error code (1) – jemz Jan 4 '18 at 7:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.