42

I am new to ubuntu, been using it for about a month now. I created this desktop for myth tv, and so i use a dual monitor configuration(one monitor for watching shows, and one for everything else). But because i dont have the tuner(yet) i am just using hulu desktop and some video files that i already have. The problem is that when i open some applications, such as firefox, they open on the monitor that is playing the video. Sometimes they even open up behind the video application. Is there a way to stick applications to a certain monitor, so that it will always open up on that application?

I was going to post an image of the display configure screen, but i am to new to post images. If you need to see an image of it let me know and i will email it to you. the image just showed my two screens, a 20" on the right, and one known as unknown on the left. The "Same image in all monitors" button is not checked.

The samsung is the monitor i want it to open on, and the unknown is the tv that i watch the videos on. Firefox in particular always opens up on the tv whenever it was closed while maximized, and opens on the screen it was closed on when it was closed while not maximized. This is the biggest annoyance that i have with ubuntu. I am coming to ubuntu from mac, and have basic to mid-level terminal experience.

  • 1
    Do you want to define in which display to open each application, or to open all new applications on a given display? – Ciro Santilli 新疆改造中心996ICU六四事件 Jan 23 '15 at 8:42
  • 1
    Adding on to Vadim's answer , you need to set "Force Placement Windows" to "Any". That fixed it for me. – Daniel Centore Jun 4 '15 at 17:21
28

If you do not have CompizConfig, install it (you need it anyway). Go to CompizConfig Settings Manager > Window Management > Place Windows (make sure that this plugin is checked). Under the General tab you see the option Multi Output Mode. You have options like: Use Active Output Device, or Use Output Device with Pointer etc.

  • 11
    Only none of those options are any good. – momomo Dec 5 '14 at 22:10
11

Something similar to this happened to me a while back. Try going to System > Preferences > Monitors. Make sure that the main monitor (your working monitor) is to the left and not the right. If the two monitors are different resoutions make sure that they both align at the top. I noticed this with my setup a couple months ago when I installed a monitor that was using a resolution way higher than my working monitor.

  • 3
    And what if the auxiliary monitor needs to be physically to the left of the main one? – Chris Stratton Jul 24 '16 at 19:18
  • Same logic applies, just make sure they align at the top no matter which side the monitor needs to be on or which virtual side you give it. – Jordon Bedwell Jul 25 '16 at 23:04
  • 2
    No, that does not solve the problem when the main monitor is on the right, as your "the same logic applies" proposal is the precise situation where the problem arises. Essentially, your answer only works for someone who wants their main monitor on the left - you haven't actually answered the question of how to specify which monitor is the main one. – Chris Stratton Jul 26 '16 at 1:42
  • 1
    @ChrisStratton: Here's the Launchpad bug for this. It hasn't actually been fixed. Exactly in your situation, primary screen to the right, I still see the bug in 16.04.1. – Dan Dascalescu Oct 1 '16 at 19:29
  • Aligning the monitors on the top fixed the problem for me (my main monitor is also on the left). – Stockfisch Oct 10 '17 at 8:24
5

Another choice is to use devilspie. You can get Devilspie from the Universe repository.

3

I believe (if you have compiz enabled) that you can do this from the compiz settings manager using the place windows plugin. I've not done this myself, but if you play around a bit with the options you should be able to get the window to appear on the desired monitor.

  • 1
    I just tried this in 12.04 and it had no effect at all, with any combination of the options. Ugh, wish this were easier. – Tom Brossman Sep 11 '12 at 19:31
3

In System->Preferences select Monitors. Check "Show Monitors in Panel" then click on the monitor you want as default and hit the "Make Default" button. Log out and back in and there you go.

I've tried this a few times and it never took until I checked the "Show Monitors in Panel" box.

  • 3
    why I can not find Show Monitors in Panel chceck box which version of ubuntu do you use? – Medya Dec 9 '12 at 21:14
2

I fixed it by using compiz-config-manager. install using

sudo apt-get install compizconfig-settings-manager

Go to General > General Options > Display Settings

Set Overlapping Output Handling to whatever display you'd prefer (the smaller or the bigger, not sure what to do when you have equally sized monitors?).

Also correctly setting the Outputs text field with your respective screen resolutions seemed to help in placing the windows better.

  • only one that worked for me. – joaoal May 10 '17 at 8:05
0

Right Click on the window titlebar and select: More Actions -▸ Window Manager Settings. There choose Focus in the column to the left. Toggle option Active screen follows mouse.

If no other defaults are specified, windows appear on the currently active screen. With the procedure described above, mouse position defines this active screen.

  • Is this a KDE only solution? – EoghanM Jul 22 '18 at 21:06
0

In "Displays" using the "Launcher placement" drop-down, select the monitor you want apps to open on.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.