I got a problem after Windows re-install, I can't set up grub properly - it doesn't detect Kubuntu, whatever I did.

At first, system & partitioning: Kubuntu 17.10 Windows 8.1

Disks mode: GPT

  • sda1 - don't know what it really is, Windows creates it automatically within installation.
  • sda2 - EFI
  • sda3 - unknown (Windows created this)
  • sda4 - Windows
  • sda5 - vfat /boot
  • sda6 - luks - vg0 (root, swap)

So, I had Windows and Kubuntu 17.10 with manually tuned luks (Special Thanks to Encrypted custom install).

Everything worked well, before I did Windows re-install and erased grub.
I tried to chroot into broken system and re-install grub

/boot - sda5
/boot/efi - sda2

apt-get purge grub-common
apt-get install grub-common
apt-get install --reinstall grub-efi

grub-install --efi-directory=/boot/efi /dev/sda

update-initramfs -k all -c

Grub is installed to /dev/sda with no mistakes, but update-grub fetchs only Windows EFI loader and doesn't recognize Kubuntu.

How can I fix it without Kubuntu re-install?

Thanks in advance :)



Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy