1

Finally trying to upgrade from 16.04 LTS to 17.04 (then to 17.10), but keep running into "Can not updrade" "Your python install is corrupted. Pleas fix the '/usr/bin/python' symlink.

I have already changed the symlink from pointing to /etc/alternatives/python, to pointing to /usr/bin/python3.5, then later to pointing to /usr/bin/python2.7, both times, forcing a reinstall of python along the way.

I keep getting the "Can not upgrade" message box. It is entirely possible there may be another issue, because along the way, it mentions Failed to download repository information and to check the Internet connection. Then, when I click OK, the software updater repairs itself to inform me that my computer is up to date, but there is a new version...

Since I can get to this forum, I believe that my connection to the Internet is OK, unless the U.S Server is down at the moment.

Any thoughts welcomed...

readlink -e /usr/bin/python /home/mitch/anaconda2/bin/python2.7

python --version Python 2.7.14 Anaconda custom (64-bit)

apt-cache policy python-minimal python-minimal Installed: 2.7.11-1 Candidate: 2.7.11-1 Version table: *** 2.7.11-1 500 500

  • Do you confirm you already tried this? askubuntu.com/a/448927/271 ...and this? askubuntu.com/a/762433/271 – Andrea Lazzarotto Jan 3 '18 at 17:50
  • Debugging upgrades is a PITA, and, due to the changes to Ubuntu, I would back up your data and do a fresh install of 17.10. In theory , if you do not format / or /home if separate, your data will be preserved, but back up in case. oh, and read the 17.10 release notes and test on a live usb. – Panther Jan 3 '18 at 18:04
  • Could you please edit your question to include the output of readlink -e /usr/bin/python, /usr/bin/python --version and apt-cache policy python-minimal? Thanks. – David Foerster Jan 3 '18 at 18:11
  • I did not try the second suggestion (didn't find it during a search). I will try that one and let you know. as far as the the output of a readlink... mitch@mitch-fortem:~$ readlink -e /usr/bin/python /home/mitch/anaconda2/bin/python2.7 mitch@mitch-fortem:~$ python --version Python 2.7.14 :: Anaconda custom (64-bit) mitch@mitch-fortem:~$ apt-cache policy python-minimal python-minimal: Installed: 2.7.11-1 Candidate: 2.7.11-1 Version table: *** 2.7.11-1 500 500 archive.ubuntu.com/ubuntu xenial/main amd64 Packages 100 /var/lib/dpkg/status – Mitch Oldroyd Jan 3 '18 at 19:19
  • OK, I tried the "update-alternatives --remove-all python". Now, update-manager still comes back with "Failed to download repository information". clicking "OK" still brings up a new dialog box "The software on this computer is up to date." However, Ubuntu... now available..." following through... still get the same "Can not upgrade"... symlink. I repeated this twice, just to make sure. – Mitch Oldroyd Jan 3 '18 at 19:52

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.