2

I installed RVM in my Ubuntu 17.10 but when I try to install Ruby I have this error:

$ rvm install 2.5.0
Searching for binary rubies, this might take some time.
No binary rubies available for: ubuntu/17.10/x86_64/ruby-2.5.0.
Continuing with compilation. Please read 'rvm help mount' to get more    information on binary rubies.
Checking requirements for ubuntu.
Installing requirements for ubuntu.
Updating systemjacques password required for 'apt-get --quiet --yes update': .-|
...
Installing required packages: libreadline6-dev....
Error running 'requirements_debian_libs_install libreadline6-dev',
please read /home/jacques/.rvm/log/1514981551_ruby-2.5.0/package_install_libreadline6-dev.log
Requirements installation failed with status: 100.

If I try to install libreadline6-dev with apt-get I receive this error:

The following packages have mismatched dependencies:
  libreadline6-dev: Depends: libreadline6 (= 6.2-9ubuntu1) but 6.3-8ubuntu8 is to be installed
  • 1
    do you have 6.2 installed? is it available in the repo? – ravery Jan 3 '18 at 12:26
  • Did you update your system before executing that command?, I just followed the instructions here: RVM Package for Ubuntu - Install and then executed rvm install 2.5.0 and it works perfectly. – galoget Jan 3 '18 at 22:07
  • galoget is your version of Ubuntu 17.10? Because I followed the instructions but I can not install any version of Ruby. Always give error when I try to install. – Jacques Marques Jan 6 '18 at 18:44
  • 1
    What's the content of /home/jacques/.rvm/log/1514981551_ruby-2.5.0/package_install_libreadline6-dev.log and the output of apt-cache policy libreadline6 libreadline6-dev? – David Foerster Jan 8 '18 at 16:25
  • The same error I said before: The following information may help resolve the situation: The following packages have mismatched dependencies: libreadline6-dev: Depends: libreadline6 (= 6.2-9ubuntu1) but 6.3-8ubuntu8 is to be installed E: Impossible to fix problems, you kept (hold) broken packages. – Jacques Marques Jan 9 '18 at 20:10
0

Here is how I solved that issue in Ubuntu 17.10:

First, install the required dependencies one by one, this can be done by executing:

sudo apt install libreadline6

sudo apt install libreadline6-dev

sudo apt install libgmp-dev

sudo apt install software-properties-common

Then proceed with the normal installation instructions:

sudo apt-add-repository -y ppa:rael-gc/rvm

sudo apt update

sudo apt install rvm

source /etc/profile.d/rvm.sh

rvm install 2.5.0

If you want, I can share screenshots of the process that I followed, step by step.

Hope it helps.

Not the answer you're looking for? Browse other questions tagged or ask your own question.