lsusb relevant output Bus 001 Device 006: ID 0bda:8812 Realtek Semiconductor Corp. RTL8812AU 802.11a/b/g/n/ac WLAN Adapter Upon plugging the device it is recognized by lsusb, however when I go to wireless settings no adapter is recognized. The driver is installed (by going to software and updates -> addition drivers and selecting the open source driver).

1 Answer 1


With a temporary working internet connection by ethernet, tethering or whatever means possible, open a terminal and do:

sudo apt update
sudo apt install git
git clone https://github.com/gnab/rtl8812au.git
sudo cp -r rtl8812au  /usr/src/rtl8812au-4.2.2
sudo dkms add -m rtl8812au -v 4.2.2
sudo dkms build -m rtl8812au -v 4.2.2
sudo dkms install -m rtl8812au -v 4.2.2

Reboot and tell us if the wireless is working.

  • Worked for me on Linux Mint 19.3 (Ubuntu 18.04.) Didn't even have to reboot.
    – Nick
    Apr 29, 2020 at 18:05
  • 1
    Worked for me on Ubuntu 16.04. Needed to reboot. A later version (4.3.8) did not work.
    – RudyF
    Dec 24, 2020 at 10:49
  • doesn't work on Ubuntu 21 Oct 29, 2021 at 22:01
  • @MykolaVeriga Please start your own new question and we'll be happy to help.
    – chili555
    Oct 29, 2021 at 23:42

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .