2

I am trying to install Ubuntu 17.10 on a Acer desktop with BIOS Version 2.14.1219 (dmesg | grep Acer reports Acer Veriton M6620G/Veriton M6620G, BIOS P01-A1L).

As far as I can tell, the Ubuntu installer books via EFI and then assumes EFI for its installation (fdisk /dev/sda reports EFI for sda1 afterwards). It does not allow me choosing otherwise.

But when I try to boot the installation I get this error: ERROR: No boot disk has been detected or the disk has failed.

When I enter a shell by selecting Try Ubuntu without installing after booting the install disk again, I can see that efibootmgr does not recognize the hard disk that received the installation as a boot entry. When I try to add it with efibootmgr -c, this setting does not persist and the firmware apparently ignores it.

dmidecode -t0 indicates that the firmware supports both UEFI (UEFI is supported) and BIOS compatibility mode (BIOS boot specification is supported). As far as I can tell, it (the BIOS) does not allow me to influence which boot mode it actually chooses.

Overall, the issue seems to consist of Ubuntu installing for EFI but the Acer firmware not being able to boot from this installation. The same happens when I attempt installing Ubuntu 16.04 (instead of 17.10).

So how can I install Ubuntu on this Acer desktop?

  • does the system allow OS selection or only device selection for boot? – ravery Jan 2 '18 at 17:29
  • @ravery Do you mean at the BIOS-level or Grub-level? – rookie099 Jan 2 '18 at 17:30
  • at the bios/firmware ... it isn't called BIOS anymore – ravery Jan 2 '18 at 17:31
  • @ravery The firmware only allows selection of boot devices. (Yes, firmware is better terminology.) – rookie099 Jan 2 '18 at 17:35
  • All Acer have a unique requirement of setting an UEFI password and then from within UEFI enabling "trust" on ubuntu/grub .efi boot files. Some systems also need newest UEFI from Acer, older threads may say downgrade UEFI, but newest works. Acer Aspire E15 will not dual boot, many details Trust settings in step 35 askubuntu.com/questions/627416/… & details, some now report that then secure boot has to be on to set trust: ubuntuforums.org/showthread.php?t=2358003 & ubuntuforums.org/… – oldfred Jan 2 '18 at 17:56
0

Most of the newer EFI firmware allows OS selection in the boot options for the internal drive. Many older systems and external drives require device boot.
In order to boot by device the default media path (EFI/BOOT/bootx64.efi) must be used.

Boot from the LiveCD, and open gparted. temporarily remove the ESP flag from the EFI partition so you can mount it. Add folder /EFI/BOOT.
Next, copy shimx64.efi and grubx64.efi from /EFI/ubuntu to /EFI/BOOT. Rename shimx64.efi to bootx64.efi.
Use gparted to reset the ESP flagg, and you should be good,

  • +1 Will try tomorrow morning CET. Just to avoid misunderstandings (since I am new to this): Does LiveCD refer to the disk with ubuntu-*-desktop-amd64.iso on it (a USB stick in my case) or the disk that received the installation? My guess is it's the first. – rookie099 Jan 2 '18 at 17:51
  • yes, LiveCD is the installer CD. it should give a try ubuntu option so you can make the changes. – ravery Jan 2 '18 at 18:14
  • I retried again, this time with ubuntu-16.04.3-desktop-amd64.iso because of this current issue in relation to Ubunto 17.10 and (certain) Acer systems. This time the system apparently installed for BIOS: Ubuntu 16.04 now can boot and fdisk /dev/sda reports no EFI partitions. Do you know if the problem to which you kindly offered a solution is specific to Ubunto 17.0? (I thought I also tried 16.04 yesterday but and ran into the same problem then.) – rookie099 Jan 3 '18 at 8:16
  • @rookie099 -- this answer applies to EFI installs that require device boot. it is not version specific. If you now have 16.04 installed in Legacy(BIOS) mode then this no longer applies. Ubuntu runs the same regardless of boot mode, so it is up to you whether you want to keep BIOS mode or try again to install in EFI mode. – ravery Jan 3 '18 at 9:40
  • Thx for your help. I'll keep BIOS (or compatibility mode, that is) for the time being. (Note to self: only difference from installing 16.04 yesterday FWIR was that today another USB device -- an iPhone for charging -- was plugged in. Unlikely that this caused the difference, though.) – rookie099 Jan 3 '18 at 12:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.