While using wifi as hotspot,it worked well for few hours but later it stopped.I started restarting the network-manager by typing the command :-

sudo systemctl restart network

It said,

Unit network.service not found
and when I typed the command :-
sudo lshw -c network
The output was this :-

mayur@mayur-HP-Notebook:~$ sudo lshw -c network
[sudo] password for mayur: 
       description: Ethernet interface
       product: RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:07:00.0
       logical name: enp7s0
       version: 07
       serial: b0:5a:da:9d:ff:2f
       size: 100Mbit/s
       capacity: 100Mbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix vpd bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=full firmware=rtl8106e-1_0.0.1 06/29/12 ip= latency=0 link=yes multicast=yes port=MII speed=100Mbit/s
       resources: irq:43 ioport:4000(size=256) memory:c5000000-c5000fff memory:c5100000-c5103fff
  *-generic DISABLED
       description: Wireless interface
       product: Illegal Vendor ID
       vendor: Illegal Vendor ID
       physical id: 0
       bus info: pci@0000:0d:00.0
       logical name: wlp13s0f0
       version: ff
       serial: 00:e0:4c:81:92:8f
       width: 32 bits
       clock: 66MHz
       capabilities: bus_master vga_palette cap_list ethernet physical wireless
       configuration: broadcast=yes driver=rtl8723be driverversion=4.10.0-42-generic firmware=N/A latency=255 link=no maxlatency=255 mingnt=255 multicast=yes wireless=IEEE 802.11
       resources: irq:16 ioport:3000(size=256) memory:c3000000-c3003fff

What should I do?

Output :-

mayur@mayur-HP-Notebook:~$ rfkill list all
0: hci0: Bluetooth
    Soft blocked: yes
    Hard blocked: no
2: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no
mayur@mayur-HP-Notebook:~$ dmesg | grep rtl
[   13.752830] Bluetooth: hci0: rtl: examining hci_ver=06 hci_rev=000b lmp_ver=06 lmp_subver=8723
[   13.752832] Bluetooth: hci0: rtl: loading rtl_bt/rtl8723b_config.bin
[   13.795239] rtl8723be: Using firmware rtlwifi/rtl8723befw.bin
[   13.800568] bluetooth hci0: Direct firmware load for rtl_bt/rtl8723b_config.bin failed with error -2
[   13.800571] Bluetooth: hci0: Failed to load rtl_bt/rtl8723b_config.bin
[   13.800576] Bluetooth: hci0: rtl: loading rtl_bt/rtl8723b_fw.bin
[   13.815172] ieee80211 phy0: Selected rate control algorithm 'rtl_rc'
[   13.815514] rtlwifi: rtlwifi: wireless switch is on
[   14.235141] rtl8723be 0000:0d:00.0 wlp13s0: renamed from wlan0
[16343.485167] Modules linked in: ipt_MASQUERADE nf_nat_masquerade_ipv4 xt_conntrack ipt_REJECT nf_reject_ipv4 xt_tcpudp iptable_filter nf_nat_h323 nf_conntrack_h323 nf_nat_pptp nf_nat_proto_gre nf_conntrack_pptp nf_conntrack_proto_gre nf_nat_tftp nf_conntrack_tftp nf_nat_sip nf_conntrack_sip nf_nat_irc nf_conntrack_irc nf_nat_ftp nf_conntrack_ftp iptable_nat nf_conntrack_ipv4 nf_defrag_ipv4 nf_nat_ipv4 nf_nat nf_conntrack libcrc32c ip_tables x_tables ccm rfcomm bnep nls_iso8859_1 hp_wmi sparse_keymap snd_hda_codec_hdmi intel_rapl x86_pkg_temp_thermal intel_powerclamp coretemp kvm irqbypass crct10dif_pclmul crc32_pclmul ghash_clmulni_intel pcbc aesni_intel aes_x86_64 crypto_simd glue_helper arc4 cryptd intel_cstate intel_rapl_perf rtl8723be(-) joydev btcoexist input_leds rtl8723_common serio_raw rtl_pci
[16343.485204]  rtlwifi mac80211 btusb btrtl intel_pch_thermal btbcm btintel snd_hda_codec_realtek cfg80211 snd_hda_codec_generic lpc_ich bluetooth snd_soc_rt298 snd_soc_ssm4567 snd_soc_rt286 mei_me snd_hda_intel snd_soc_rl6347a shpchp mei snd_soc_core snd_hda_codec processor_thermal_device snd_compress intel_soc_dts_iosf ac97_bus snd_hda_core snd_pcm_dmaengine snd_hwdep snd_pcm snd_seq_midi snd_seq_midi_event snd_rawmidi snd_seq int3403_thermal snd_seq_device snd_timer snd int3402_thermal int340x_thermal_zone snd_soc_sst_acpi soundcore dw_dmac snd_soc_sst_match dw_dmac_core spi_pxa2xx_platform i2c_designware_platform i2c_designware_core 8250_dw int3406_thermal tpm_crb int3400_thermal acpi_thermal_rel hp_wireless acpi_pad mac_hid parport_pc ppdev lp parport autofs4 i915 i2c_algo_bit drm_kms_helper syscopyarea
[16343.485326]  rtl_pci_disconnect+0x193/0x1e3 [rtl_pci]
[16343.485345]  rtl8723be_driver_exit+0x10/0x6be [rtl8723be]
[16378.491054] rtl8723be 0000:0d:00.0: Refused to change power state, currently in D3
[16378.491298] rtl8723be: Using firmware rtlwifi/rtl8723befw.bin
[16378.492553] ieee80211 phy0: Selected rate control algorithm 'rtl_rc'
[16378.493271] rtlwifi: rtlwifi: wireless switch is on
[16378.514839] rtl8723be 0000:0d:00.0 wlp13s0f0: renamed from wlan0
  • Please edit your question to show the result of the terminal commands: rfkill list all and also: dmesg | grep rtl – chili555 Jan 2 '18 at 16:01
  • edited the question @chill555 – mike Jan 2 '18 at 18:45
  • Have you selected the correct antenna? askubuntu.com/questions/991418/… – chili555 Jan 2 '18 at 21:08
  • I had selected ant_sel=2 – mike Jan 3 '18 at 2:02
  • Is there any change if you try ant_sel=1? – chili555 Jan 3 '18 at 2:16

We see some interesting clues in lshw:

*-generic DISABLED
       description: Wireless interface
       product: Illegal Vendor ID
       vendor: Illegal Vendor ID
       physical id: 0
       bus info: pci@0000:0d:00.0

And in dmesg:

[16343.485345]  rtl8723be_driver_exit+0x10/0x6be [rtl8723be]
[16378.491054] rtl8723be 0000:0d:00.0: Refused to change power state, currently in D3

The illegal vendor ID is sometimes observed with parts purchased overseas that are apparently cheap clones. It is sometimes also observed in parts that have failed electrically. In either case, I suggest that your laptop is in need of a replacement wireless card.

  • But in when I had windows 10 in my laptop,there was no issue regarding wireless card.It ran without any problem.But when I installed ubuntu 16.04 freshly,I had this problem. – mike Jan 3 '18 at 16:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.