0

This question already has an answer here:

In this post I look rather for clarification than technical solution (the problem is already solved, see below).

I just upgraded from 14.04 to 16.04 and installed a fresh Firefox, which happened to be Quantum 57.0.3 (64 bit). Flash didn't work, thus I installed flashplugin-installer, which has in its description:

The Adobe Flash Player plugin will work with a range of web-browsers >including, limited to: * Firefox

Unfortunately it didn't help. What helped was the installation of browser-plugin-freshplayer-pepperflash instead. The description of the latter package states:

The main goal of the project is to get PPAPI (Chrome) plugins working in Firefox (and any other web-browser supporting NPAPI plugins

I wanted to understand why the former package didn't work, thus I started to read and found out here that Firefox since ver 52 does not support NPAPI plugins, except for Adobe Flash. Therefore, it seemed that having adobe-flashplugin installed should be enough and one does not need to deal with the NPAPI/PPAPI issues. Indeed, after I removed browser-plugin-freshplayer-pepperflash and sticked to adobe-flashplugin, everything worked fine. Thus, I suspect that the crux was in one of the packages required by browser-plugin-freshplayer-pepperflash, not that package itself.

Would the conclusion be that Firefox in 16.04 ships without Flash support, even when adobe-flashplugin is present (I wonder why)? If so, some users might bump at this problem, just as I did.

marked as duplicate by Eric Carvalho, David Foerster, waltinator, Charles Green, pomsky Jan 5 '18 at 8:01

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • The official Flash Player package (see the linked question) for Ubuntu uses the newer PPAPI in Firefox and other browsers. – David Foerster Jan 2 '18 at 22:39
2

I cannot make sense of your observations that adobe-flashplugin works without browser-plugin-freshplayer-pepperflash but flashplugin-installer does not. adobe-flashplugin and flashplugin-installer provide the very same NPAPI plugin. Maybe you simply forgot to restart your browser or something...

This page provides a concise summary on the topic, including an attempt to explain when browser-plugin-freshplayer-pepperflash may be a useful.

  • Indeed, the fact I used two different packages is only confusing, that was not supposed to be my main point. It was supposed to be that after I installed and removed browser-plugin-freshplayer-pepperflash, flash started to work, thus I thought that there was an indispensable package in its dependencies, which 'enabled' the adobe flash player (regardless to the package it came from). – Maciek Jan 2 '18 at 16:35
  • @Maciek: Ok. I still think it was merely a coincidence. Installing either flashplugin-installer or adobe-flashplugin and restarting Firefox ought to be sufficient. – Gunnar Hjalmarsson Jan 2 '18 at 17:31

Not the answer you're looking for? Browse other questions tagged or ask your own question.