1

My system does not hibernate or suspend automatically when asked to in dconf configuration files. I have tried some workarounds and I eventually found a script that used to work however with a new fresh installation of Ubuntu the script just poweroff the whole system (Won't Hibernate when Battery Critical - answer by Goghard). I also tried to modify the grub file by myself, with no success unfortunately.

My ultimate scope is to suspend the system at a critical level defined by % battery level.

I attach also the partitions of my system, I added recently another swap partition to attempt to fix the problem.

    NAME   MAJ:MIN RM   SIZE RO TYPE MOUNTPOINT
sda      8:0    0 256,2G  0 disk

─sda1   8:1    0   476M  0 part /boot

─sda2   8:2    0  55,9G  0 part /

─sda3   8:3    0   3,7G  0 part [SWAP]

─sda4   8:4    0    95M  0 part /boot/efi

─sda5   8:5    0 186,3G  0 part /home

─sda6   8:6    0   9,8G  0 part [SWAP]

sr0     11:0    1  1024M  0 rom  

The grub file reports the following:

# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0
GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="resume=/dev/sda6"

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"`

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.