2

I'm playing with a new ASUS ROG GL503VD-DB71 laptop onto which I've installed a fresh Ubuntu 17.10 Aardvark with GNOME Shell. Everything works beautifully except the touchpad, which I've so far had no luck diagnosing.

The touchpad calls itself ELAN1200:00 04F3:3090. dmesg picks up the keyboard/touchpad devices on an i8042 interface. Some possibly relevant output:

[    1.162907] serio: i8042 KBD port at 0x60,0x64 irq 1
[    1.162910] serio: i8042 AUX port at 0x60,0x64 irq 12
[    4.550906] i2c_hid i2c-ELAN1200:00: i2c-ELAN1200:00 supply vdd not found, using dummy regulator
[    5.238262] input: ELAN1200:00 04F3:3090 Touchpad as /devices/pci0000:00/0000:00:15.0/i2c_designware.0/i2c-5/i2c-ELAN1200:00/0018:04F3:3090.0003/input/input15
[    5.238316] hid-multitouch 0018:04F3:3090.0003: input,hidraw2: I2C HID v1.00 Mouse [ELAN1200:00 04F3:3090] on i2c-ELAN1200:00

Symptoms are:

  • The touchpad works, but the response is very sluggish, with very noticeable delay and lag. I'd describe the feel as if one was using a 10 year old machine that was under high CPU load. Basically, the pointer doesn't smoothly glide, but jumps around. This is probably the same behaviour that is described in Asus FX503VD Elan1200 Touchpad not working smoothly.

  • The mouse clicks all the time when it's moving, so that it's usually drawing a selection box on the desktop (i.e., left click). I can also manually trigger a left click by tapping (tap click is turned on in GNOME settings), or by using the left button. Right click works fine with double-finger tap or right button. Scrolling with two fingers works.

  • top shows a process called irq/255-ELAN120 that consistently uses about 10% of the CPU.

These problems appear when using the nvidia-384.90 driver, both with prime-select using the discrete GTX 1050 with x11 and with prime set to run on the integrated Intel graphics under wayland. I also have the same problem when running on the nouveau driver under wayland.

If I disable the touchpad in the BIOS, the irq/255-ELAN120 process is not there anymore. This increases my battery life on idle from three hours to over four hours.

I have tried various combinations of kernel options (as described in Touchpad not freezing and moving slow and What does the 'i8042.nomux=1' kernel option do during booting of Ubuntu?), including i8042.nomux=1, i8042.kbdreset=1 and i8042.reset without noticeable improvement.

Watching libinput-debug-events, I also can't really attest to any obvious lag in the printed output. With libinput-debug-events --enable-tap, I can see the phantom click events happening; these occur the first time I put my finger down on the touchpad, and are also sort of randomly sprinkled while the mouse is moving.

Software versions are linux 4.13.0-21-generic x86_64, GNOME 3.26.1, libinput 1.8.2-1ubuntu2, xserver-xorg-input-libinput 0.25.0-0ubuntu1.

I plan to try updating to the latest release of libinput, and also to try booting from an older Ubuntu image, and update this question if there is anything further to report.

Any help is most appreciated.

  • 1
    Same problem on ASUS GL703VD – Zibri Jan 20 '18 at 9:56
  • for me touchpad worked only with acpi=force in grub params, still it's working badly, just like you describe – Rodislav Moldovan Jan 28 '18 at 2:05
  • I have the same problem, I tried on Ubuntu 17.10, Xubuntu 16.04, Linux Mint 18.3, Antergos, and Solus 3 GNOME. – ClementNerma Feb 24 '18 at 13:19
  • Hi folks, thanks for the feedback. I haven't had much time to keep debugging this issue, but I've opened a bug on kernel.org here: bugzilla.kernel.org/show_bug.cgi?id=198473 – wildwilhelm Feb 24 '18 at 18:07
1

Some RedHat folks have been working this here: https://bugzilla.redhat.com/show_bug.cgi?id=1543769

Apparently the fix is in kernel-4.17.0-0.rc4. There are builds that can be tested for redhat at https://koji.fedoraproject.org/koji/buildinfo?buildID=1080723, but I don't know of an Ubuntu build at this time.

  • I have the same problem and am testing with kernel-4.17.0-rc4 and kernel-4.17.0-rc5, where the problem is not solved, unfortunately. – Tim May 16 '18 at 19:08
  • This is mostly working for me in Ubuntu 18-10. It can still go crazy at times. The fix is to remove and the re-install the module. – Dan Christian Dec 14 '18 at 16:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.