1

I have just upgraded from ubuntu 16.04 to ubuntu 17.10. My touchpad was working on ubuntu 16.04 and also on live usb of 17.10. But, it is not working after installation. My laptop is Dell inspiron 3521

Here the things I did so far:

1) Install xserver-xorg-input-synaptics

Touchpad worked after reboot but stopped working until now after another reboot

2) Upgraded kernel to 4.14.0-041400-generic from 4.13

3) Tried copying /usr/share/X11/xorg.conf.d/70-synaptics.conf to /etc/X11/xorg.conf.d

4) Tried commenting out below lines in 40-libinput.conf

Section "InputClass"
    Identifier "libinput touchpad catchall"
    MatchIsTouchpad "on"
    MatchDevicePath "/dev/input/event*"
    Driver "libinput"
EndSection

5) Removing xserver-xorg-input-synaptics

Nothing worked so far

0

Run this command in terminal:

sudo gedit /etc/default/grub

You will find a line like this:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

Now replace "quiet splash" with "acpi=force"

So the new line will be:

GRUB_CMDLINE_LINUX_DEFAULT="acpi=force"

Save the file.

Now run this command:

sudo update-grub

This should solve your problem.

1
  • Thank you for your reply but this didn't solve my problem :( – programmer Jan 1 '18 at 10:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.