0

Using my Ubuntu USB backup, connected to the internet and followed instructions to download, install and run Boot Repair via Terminal.

From Terminal to run okay the first time but got message about Secure Boot needing to be turned off. Then it continued running, but problem was not solved and computer could not reboot.

Got message http:paste.ubuntu.com/26291725

Turned off Secure Boot, installed and ran etc again and it's stuck on the following.. Boot repair search mode has been running for more than several minutes...

After some time I got the main graphical menu and selected the normal repair

Now this has been up for 20+ minutes with the Grub problem

Grub problem

No idea what to do next...


Update 1:

Some time later the task was complete and I got the following message:

An error occurred during the repair. A new file (/var/log/boot-repair/20171231_084453/Boot-Info_20171231_084‌​4.txt) will open in your text viewer. In case you still experience boot problem, indicate its content to: boot.repair@gmail.com Locked-ESP detected. You may want to retry after creating a /boot/efi partition (FAT32, 100MB~250MB, start of the disk, boot flag). This can be performed via tools such as gParted. Then select this partition via the [Separate /boot/efi partition:] option of [Boot Repair]

Update 2:

Sent logs to bootrepair email. Was not able to reboot from hard drive. Was able to boot up from Ubuntu USB and login (as you can see) to Ask Ubuntu via my Google ID. Checked email... no response yet.

Update 3:

Ran gparted as suggested above. Got the following error: Gparted I/O problem

SrartDatafail

Update 4 Ran gparted agaun - results

Update 5 enter image description here

Update 6 Should I run Gparted data rescue?enter image description here

message during startup

unable to handle kernel - crash during while running off of USB

close-up of kernel message

Update 1.12.2018 gparted screenshot gparted screenshot This came up a few time before finishing gparted report

  • Locked ESP error. See if dosfsck like this works: askubuntu.com/questions/862724/grub2-failed-to-install/… Others have had to back up the ESP - efi system partition (FAT32 with boot flag), delete it and then recreate it and restore files. But UUID & GUID then will change and other updates like reinstall grub and Windows UEFI boot entry are required. – oldfred Dec 31 '17 at 22:26
  • @oldfred - Thanks, but I am a little lost. Should run sudo dosfsck-aAbflrtvVwy in Terminal? – Todd Edelman Jan 1 '18 at 0:22
  • You need to run from terminal in live installer: sudo dosfsck -t -a -w /dev/sda1 and see if that solves issue or not. – oldfred Jan 1 '18 at 4:45
  • Is the live installer the version of Ubuntu I am using that's on the USB? That' what I am using now. ubuntu@ubuntu:~$ sudo dosfsck -t -a -w /dev/sda1 fsck.fat 3.0.28 (2015-05-16) /dev/sda1: 238 files, 42435/98304 clusters ubuntu@ubuntu:~$ – Todd Edelman Jan 1 '18 at 9:10
  • Yes, and after the file check does gparted work or are there other issues? What brand/model system and what drive. Many SSD have needed firmware updates. – oldfred Jan 1 '18 at 16:04
1

Gparted error on sda3, system reserved is normal as that is required to be unformatted, but then gparted throws an error. The error on sda4 is only normal if you can directly boot Windows and then that says your have fast startup still on. But error on ext4 partition, sda8, says you may need fsck.Run both of these commands on sda8. Ubuntu 14.04 is not booting normaly after a manual hard boot

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.