2

Whenever I use Chromium my computer crashes after some time. Like, if I just open it once, and then close, then my computer crashes later on and I have to restart my computer.

There are lot of questions on how to stop Chromium from crashing. Chromium has no problem whatsoever when I use it. The problem I am having is that my Ubuntu 16.04 crashes if I use Chromium at least once.

Edit:

I tried opening it through the terminal. It didn't open. This is the error I got:

[3875:3875:1231/134723.051486:ERROR:process_singleton_posix.cc(433)] readlink failed: Permission denied (13)
[3875:3875:1231/134723.051538:ERROR:process_singleton_posix.cc(256)] readlink(/home/albin/.config/chromium/SingletonLock) failed: Permission denied (13)
[3875:3875:1231/134723.051568:ERROR:process_singleton_posix.cc(256)] readlink(/home/albin/.config/chromium/SingletonLock) failed: Permission denied (13)
[3875:3875:1231/134723.051584:ERROR:process_singleton_posix.cc(280)] Failed to create /home/albin/.config/chromium/SingletonLock: Permission denied (13)
[3875:3875:1231/134723.051613:ERROR:process_singleton_posix.cc(433)] readlink failed: Permission denied (13)
[3875:3875:1231/134723.051628:ERROR:process_singleton_posix.cc(256)] readlink(/home/albin/.config/chromium/SingletonLock) failed: Permission denied (13)
[3875:3875:1231/134723.051707:ERROR:chrome_browser_main.cc(1496)] Failed to create a ProcessSingleton for your profile directory. This means that running multiple instances would start multiple browser processes rather than opening a new window in the existing process. Aborting now to avoid profile corruption.
[3875:3909:1231/134723.391975:ERROR:browser_gpu_channel_host_factory.cc(107)] > Failed to launch GPU process.

This is the error I get when I try to run it with sudo:

[4111:4111:1231/135149.919427:ERROR:zygote_host_impl_linux.cc(88)] Running as root without --no-sandbox is not supported. See https://crbug.com/638180.

Edit 2:

I tried the answer given in this question. It solved most of the issues I guess... but this is what I get now:

ATTENTION: default value of option force_s3tc_enable overridden by environment.
[5106:5106:1231/142053.572447:ERROR:navigation_entry_screenshot_manager.cc(135)] Invalid entry with unique id: 1
  • Have you tried opening chromium from terminal. Edit the question and post your output from terminal – TheOneAboveAll Dec 31 '17 at 8:05
  • It says it's not installed. I installed chromium from Ubuntu Software – Albin Does Games Dec 31 '17 at 8:10
  • @AlbinDoesGames Are you talking about the Chromium web browser? In Ubuntu, the command to run the Chromium browser is chromium-browser, not chromium. Might that account for how you were unable to run it from the command-line? If so, you should be able to run it from a terminal by typing chromium-browser, to obtain the information requested here, which you can then edit your question to provide. Based on your description, I am not really sure if it will be useful, since you said the effect was to destabilize your system rather than to crash immediately. Still, it's worth a try, I think. – Eliah Kagan Dec 31 '17 at 8:24
  • yeah @EliahKagan I tried chromium-browser in the terminal. I also added error message I got( I have edited and added it in the question) – Albin Does Games Dec 31 '17 at 8:29
  • @AlbinDoesGames Thanks. It appears to be the same problem as described in that other question. The solutions posted there should help. – Eliah Kagan Dec 31 '17 at 8:31

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.