I'm trying to install the google music plugin for Rhythmbox(link)
Now this plugin also requires 'gmusicapi'(link)
I was able to install both these packages without any errors. When I open Rhythmbox and try to enable the google music plugin, the player crashes.

I tried running the player in debug mode from terminal by using rhythmbox -d
When I try to enable the plugin, it throws this error: This program requires version 3.5.0 of the Protocol Buffer runtime library, but the installed version is 3.0.0. Please update your library. If you compiled the program yourself, make sure that your headers are from the same version of Protocol Buffers as your link-time library.

Questions:

  1. How do I fix this? I have installed protobuf 3.5.o and my protobuf-compiler version is 3.0
    I believe both are the latest
  2. A questions about the gmusicapi: Where should I include this authentication code link
    I started a python shell in Ubuntu terminal and was able to get a python list of my google play music library. But when I try to do the same in the Rhythmbox python shell, I get the same error

Please help. If someone is using the google play music plugin please assist.
Please let me know any additional debugging steps that I can follow to help me solve this problem.

PS: I'm using Ubuntu 17.10

For Ubuntu 14.xx or Later Users

Canonical's repos package Rhythmbox 3 beginning with Ubuntu 14.04 Trusty Tahr. If you are running Ubuntu 14 or later, you will need to add the Saucy repos to your sources, and downgrade to Rhythmbox 2.99 to use this plugin.

Have you downgraded your Rhythmbox?

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.