2

I was having problems with a hybrid graphics laptop with a 1060 and an intel HD 530. I followed this tutorial where I created a nomodeset option at boot for using the integrated card and a regular boot option for using the nvidia card. The nvidia boot works fine however on the intel boot, even after installing the latest intel drivers with the Intel Graphics Update Tool for Linux, the resolution is stuck at 800x600 and I cant adjust screen brightness. I used prime-select to make sure the integrated graphics is running.

The power draw on the Nvidia card is horrendous. I need to use the laptop on the go so getting integrated graphics to work is a must. I'd appreciate any help.

  • I've had no end of trouble trying to get my 970m to power down while in Intel GPU mode. This guide worked for me, but I have an older laptop with a setting in the BIOS to switch between "MSHYBRID" and "DEDICATED" GPU modes. The three main things that got mine working was installation of latest kernel (4.14), latest Nvidia driver (384.69), and the "!Windows 2015" setting in my GRUB_CMDLINE_LINUX_DEFAULT. Unfortunately, every hybrid GPU laptop seems to be different, so I don't think there's a universal solution. – Vanessa Deagan Dec 30 '17 at 19:53
  • I tried both those options but neither worked. I am still stuck at 800x600 – Butter Jan 1 '18 at 13:22
0

I know this isn't much of a fix but upgrading to 17.10 fixed everything. I'm hopping 18.04 will continue support.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.