0

It seems like a very common problem. It happens to me almost 3-4 times a month. I can't turn on by any means. I tried almost every solution available on askubuntu, and other forums.

  1. sudo rfkill unblock bluetooth This command seem to be very useful to most of linux users but unfortunately not for me.
  2. Tried installing all necessary packages for bluetooth

sudo apt-get install bluetooth bluez bluez-tools rfkill

It did not turn on the bluetooth.

  1. sudo rfkill list It shows that all of my bluetooth devices are not blocked in any way.

0: phy0: Wireless LAN
Soft blocked: no
Hard blocked: no

1: acer-wireless: Wireless LAN
Soft blocked: no
Hard blocked: no

2: acer-bluetooth: Bluetooth
Soft blocked: no
Hard blocked: no

  1. More commands

    sudo rfkill unblock bluetooth

Make sure the Bluetooth service is active by running the following command.

sudo service bluetooth start

These commands do not show any error. I tried to use GUI. I saw that bluetooth was still disabled.

  1. Output of lspci -nnk | grep -iA3 net;

02:00.1 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [10ec:8168] (rev 12) Subsystem: Acer Incorporated [ALI] RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [1025:0940] Kernel driver in use: r8169 Kernel modules: r8169 03:00.0 Network controller [0280]: Qualcomm Atheros QCA9565 / AR9565 Wireless Network Adapter [168c:0036] (rev 01) Subsystem: Lite-On Communications Inc QCA9565 / AR9565 Wireless Network Adapter [11ad:0642] Kernel driver in use: ath9k Kernel modules: ath9k 04:00.0 3D controller [0302]: NVIDIA Corporation GF117M [GeForce 610M/710M/810M/820M / GT 620M/625M/630M/720M] [10de:1140] (rev a1)

6. Output of lsusb

Bus 001 Device 002: ID 8087:8001 Intel Corp. Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub Bus 003 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub Bus 002 Device 003: ID 04f2:b452 Chicony Electronics Co., Ltd Bus 002 Device 002: ID 04ca:300b Lite-On Technology Corp. Atheros AR3012 Bluetooth Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

7. Output of dmesg | egrep -i 'blue|firm';

[ 1.426497] [Firmware Bug]: ACPI(PXSX) defines _DOD but not _DOS [ 12.668914] Bluetooth: Core ver 2.21 [ 12.668934] Bluetooth: HCI device and connection manager initialized [ 12.668938] Bluetooth: HCI socket layer initialized [ 12.668942] Bluetooth: L2CAP socket layer initialized [ 12.668948] Bluetooth: SCO socket layer initialized [ 18.038328] Bluetooth: Can't get version to change to load ram patch err [ 18.038333] Bluetooth: Loading patch file failed [ 44.855708] Bluetooth: BNEP (Ethernet Emulation) ver 1.3 [
44.855712] Bluetooth: BNEP filters: protocol multicast [ 44.855716] Bluetooth: BNEP socket layer initialized [ 5647.817993] [Firmware Bug]: battery: (dis)charge rate invalid.

What could be the possible reason? On next boot, it works normally. What could be the solution? I do not want to restart PC just to turn on bluetooth.

  • Please edit to include results for `lspci -nnk | grep -iA3 net; lsusb; dmesg | egrep -i 'blue|firm' – Jeremy31 Dec 30 '17 at 16:52
  • okay , I' ll. wait. – Purushotam Sangroula Dec 30 '17 at 16:52
  • @Jeremy31 please check my updated question. – Purushotam Sangroula Dec 30 '17 at 17:06
  • @Anime, wold it be possible for you to format the sections you cut and paste from the terminal to look a little more like the actual output? With everything on one line, it is hard to decipher. A suggestion would be to copy and paste from the terminal into gedit. Then, select everything and press Tab a couple of times to indent. Finally select the modified text, and paste it into your question. Then it will formatted the way you see it in your terminal, and will be easier for all of us to read. – PJ Singh Dec 30 '17 at 22:01
  • @PJSingh It would have been, yesterday, but today I have bluetooth enabled. So I'll do the same when same thing happens. It is frequent in my PC. – Purushotam Sangroula Dec 31 '17 at 5:00

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.