33

I have a custom .desktop file:

[Desktop Entry]
Type=Application
Terminal=false
Icon[en_US]=/home/alex/bin/idea-IC-173.4127.27/bin/idea.png
Name[en_US]=IntelliJ
Exec=/home/alex/bin/idea-IC-173.4127.27/bin/idea.sh
Name=IntelliJ
Icon=/home/alex/bin/idea-IC-173.4127.27/bin/idea.png

Output of ls -lha .local/share/applications/intellij.desktop:

-rwx--x--x 1 alex alex 248 Dez 30 10:54 .local/share/applications/intellij.desktop

Answers posted to a previous question (How can I add custom '.desktop' application launchers to Ubuntu Dock?) don't work for me. I can find this launcher in Activities and I can double click on that file and IntelliJ will start. Nevertheless, I cannot add this launcher as a favorite to the dock. The option does not show up.

  • All of the responses here are how to set the favorites. I don't see any responses about how to add one without having prior knowledge of what favorites are there. askubuntu.com/questions/1193496/… This question might be helpful to people in my situation. – Michael Ziluck Jun 11 at 20:41
38

Open Terminal and run

gsettings get org.gnome.shell favorite-apps

You should get the list of .desktop files associated to the apps pinned to Ubuntu dock in order, something like the following:

['appname-1.desktop', 'appname-2.desktop', 'appname-3.desktop', 'appname-4.desktop', 'appname-5.desktop']

Suppose you want to pin the app associated to the intellij.desktop file as the second item in the dock. In that case, run

gsettings set org.gnome.shell favorite-apps "['appname-1.desktop', 'intellij.desktop', 'appname-2.desktop', 'appname-3.desktop', 'appname-4.desktop', 'appname-5.desktop']"
| improve this answer | |
  • 1
    This works! But when I start the app, another app icon appears. imgur.com/a/8GZ7j – kerner1000 Jan 4 '18 at 18:06
  • 6
    @kerner1000 Try this: askubuntu.com/a/975230/480481 from step 4 onwards – pomsky Jan 4 '18 at 18:15
  • 2
    Works! Thanks a lot! I got acutally two strings back from xprop, I used the second one (jetbrains-idea-ce). – kerner1000 Jan 4 '18 at 18:43
  • It may be more user-friendly to put it this way: wherever you put a .desktop file, make it executable and trustable when clicking to open it, then right-click on the icon in the dock and add to the favourites. – funicorn Jan 6 '18 at 3:39
  • 1
    @funicorn As per OP, the others methods (e.g. Add to favourites) mentioned in older questions are not working for them. That's why they asked a new question. – pomsky Jan 6 '18 at 7:04
15

The answer from @pomsky is correct, but there is an easier way: use

dconf-editor  

(install it with sudo apt-get install dconf-editor if not installed) and navigate to

org/gnome/shell/favorite-apps.

There it is possible to edit and rearrange the Launcher.

| improve this answer | |
4

This can happen when the StartupWMClass doesn't correspond to the WMClass of the application. See this question for details on how it works and how to find the WMClass. In my case, setting the correct StartupWMClass in the .desktop file fixes this issue.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.