2

I was trying to install Champions of Regnum, I downloaded the linux installer 64bit, changed the permissions and executed it. But after it was done installing, I got it in the softwares and on the desktop, but neither of which would open when double clicked.

So I tried reusing the installer through the terminal and after it was finished I got the following error message.

/usr/local/regnum/rolauncher: error while loading shared libraries: libpng12.so.0: cannot open shared object file: No such file or directory
1
  • Can't run it on Ubuntu 20 too. Downloaded and installed ROInstall_64. Installation finished. In the login screen I cannot even see what I'm typing. After blindly entering correct username/password the application just stops. No error message, nothing.
    – A.W.
    Commented Nov 1, 2020 at 7:00

1 Answer 1

0

Manually downloading libpng12-0 from this site and installing it worked for me.

I also had a problem with libjpeg, which was solved installing sudo apt install libjpeg62. And then I had to run the launcher using sudo /usr/local/... to avoid a warning.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .