2

I've just bought a Gigabyte Technology Co., Ltd. Z370 AORUS Ultra Gaming-CF, using it with an i7-8700k.

Issue I have is that I can't get the fan speed and whatnot - just CPU temperatures with coretemp.

I've raised a bug on https://github.com/groeck/lm-sensors/issues/44 to ask the author if I should do anything, he suggested loading the driver it87. I have to say, when I run sensors-detect, it doesn't come suggested, hence not sure what I should do next.

I'm running kernel 4.10.0-42-generic.

Thanks!

0

Apparently is not possible without intervention with current Ubuntu distributions (and if things stay as those are even with next LTS 18.04).

If one wants now to use it, he/she will have to manually resort to downloading and compiling such driver from https://github.com/groeck/it87 and follow the instructions there.

This is less than ideal, that's why I've raised an Ubuntu question https://answers.launchpad.net/ubuntu/+question/662421 to update the it87 driver.

Edit

As per suggestions, raised a bug https://bugs.launchpad.net/ubuntu/+bug/1740736 for Ubuntu folks to cater for latest driver...

| improve this answer | |
0

Here's what worked for me:

  • Edit boot parameters in /etc/default/grub
  • Add:

    acpi_enforce_resources=lax thermal.off=1 module_blacklist=eeepc_wmi
    
  • Run:

    sudo update-grup
    
  • Edit /etc/modules

  • Add: nct6775
  • Restart
  • Run: sensors
  • Optionally create /etc/sensors.d/asus as described in this Reddit thread.

Sources:

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.