1

I'm using a lenovo ideapad 700 (i5-6300HQ and GTX 950M), optimus based(?) laptop.

My goal would be to use the GPU for openCL or CUDA computing mainly, so using the GPU to display games/desktop isn't a priority at all(still would be nice though).

The problem is, I can't get past installing the nvidia drivers properly. It installs with no issues, however it simply just isn't used.

After installing lshw just says that it's using the nouveau driver, but when blacklisting (or modeset=0) it, the GPU will become unclaimed with no drivers.

I tried all kind of driver versions, even separately getting just the CUDA sdk, but it still relies on the driver.

Could anyone give me an installation method that works?

Also do I need to use bumblebee, if yes, can I access the GPU through it with openCL and CUDA tools directly?

I haven't tried installing bumblebee after I upgraded to 17.10, because it might not be stable, but if anyone could confirm that it works, I'd try it.

Update: I'm using the 4.14.10-* kernel atm, and DKMS will throw compile errors saying that the headers aren't supported.

Switching back to 4.13.* will solve the installation errors, but the driver will cause black screens and freezes, and a list of errors at boot.

7
  • How have you installed the drivers you tried? Software Updater/ Additional Drivers tab should list the available ones, select the "tested" one.
    – ubfan1
    Dec 29, 2017 at 22:57
  • Firstly I tried the GUI way, but it essentially does the same, so I'd rather stick to the shell. I'd just do "apt purge nvidia* && apt autoremove" then "apt install nvidia-3xx" for each try. I tried with different kernels as well, on 4.13.* it will install just fine, however it either gives an error or a black screen. On 4.14.* however it won't even install, and DKMS will give a lot of compilation errors.
    – tamasfe
    Dec 30, 2017 at 1:02
  • The gui should get all the necessary packages like the nvidia-384-dev, nvidia-modprobe etc. The necessary compiles will need the -dev package, sounds like you're missing that.
    – ubfan1
    Dec 30, 2017 at 1:14
  • But unfortunately it didn't(or it did, but still no success), if the gui installation worked, I wouldn't have even touched the shell.
    – tamasfe
    Dec 30, 2017 at 1:20
  • If the nvidia driver loads, but you get the black screen, there are lots of solutions to that problem on this site. If the driver does not load, at this point, check the /etc/modprobe.d dir for any leftover blacklist...<your selected driver> lines in any file which might be leftovers from previous installs, and delete them.
    – ubfan1
    Dec 30, 2017 at 4:00

2 Answers 2

2

I managed to temporarily "fix" it.

And my assumption after some testing is that there are 2 kinds of issues present:

First, newer 4.14.*+ kernels aren't supported by the nvidia drivers yet, so they will fail to install properly, however it isn't obvious.

This was rather hard to find out, as instead of big flashing "ERROR"s, and install failure, I got an install success saying the drivers were installed, with a well-hidden DKMS error. If I use the GUI installer, the error isn't even shown.

Anyway, the fix for this is to revert to an older kernel, pretty much straightforward.

Second, the new GDM3 has issues with nvidia drivers, and will fail to load properly.

A solution for this is to temporarily switch to lightDM, even though I prefer the look of GDM3 by a lot, having a functioning gpu is more important at the moment.

Overall:

I'm using a 4.13.10-* kernel, with an nvidia-384 driver, with no secure boot (no UEFI either), and just to be sure "nouveau.modeset=0" added to kernel parameters.

I haven't tried bumblebee, but I don't need it at the moment that much, and I'm happy that at least the drivers work.

I'm going to report both issues at launchpad, if they aren't reported yet.

update: There is an open bug for the nvidia drivers, apparently it's indeed Wayland related, so it's likely to be fixed in 18.04 (hopefully).

another update: It is actually enough to disable Wayland altogether in GDM3, the steps are described here: How to disable wayland in 17.10 in gdm3 login screen

2
  • How do I properly downgrade my kernel on 18.04? The oldest search result for apt search linux-image is 4.15. May 7, 2018 at 23:45
  • 1
    Download a kernel from here kernel.ubuntu.com/~kernel-ppa/mainline , you'll need a header and the image for each kernel, you'll most likely need "linux-headers-4...._all.deb" and and "linux-image-4...-generic...deb". Choose amd64 if you have a 64bit machine, or i386 if you have a 32bit machine. Then you can install them like any other .deb packages with "sudo dpkg -i <filename>.deb", then you can select the kernel in "ubuntu advanced options" or something like that at boot in GRUB.
    – tamasfe
    May 9, 2018 at 11:04
0

I have the same video card as you GTX 950M. I succeed by installing nvidia drivers from Proprietary GPU drivers PPA. I'm using kernel 4.13.0-25-generic in Ubuntu 17.10 with Gnome installed. Everything is running accordingly. No blank screen, none of the problems that you are describing right here.

sudo add-apt-repository ppa:graphics-drivers/ppa
sudo apt-get update
sudo apt-get remove nvidia*
sudo apt-get install nvidia-384 nvidia-384-dev

Reboot after finishing the procedure.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .