Actually I met a similar issue as this one:AMD Radeon APU and Ubuntu 16.04.3 And I don't think it's an driver issue. I am working on a ASUS F402BA and it has AMD A9-9420 Processor, Radeon R5 Graphics with 8GB DDR3 RAM.

It has a wifi adapter Qualcomm Atheros Device 0042.

Currently steady Ubuntu distributions are 14.04 and 16.04. I am trying both.

Ubuntu 16.04 will work for a while (~30 min) on my machine and it will become slow/not interacting:

  1. Everything on the screen stops except that the mouse can move.
  2. The mouse can move, but it cannot click. When the mouse is moving upon any icon, target icon does not react at all, not changing lightness etc.
  3. On keyboard side, when typing Alt+Shift+Screenshot REISUB ,Ubuntu will restart, but any keyboard input won't show up on screen, for instance, pressing home key does not brings searching menu.

But I tried Ubuntu 14.04, and it works well on this machine, except the fact that it does not have the corresponding wifi driver: Qualcomm Atheros Device 0042.

So I still prefer to stick to steady ubuntu 16.04. Could anyone help me on this?


I had a very similar issue, just today I tried installing Ubuntu 17.10 to see if maybe it would work better which it seems to thus far (have only been testing it out for a couple hours now but haven't had any more issues). Maybe give that a try?

| improve this answer | |
  • Yes, actually I tried ubuntu 14.04 and 17.10, both of these versions is compatible with my laptop. Thanks for your reply. – Yerong Li Jan 5 '18 at 22:59

Ok, I suffered from the same problem. I installed Elementary OS, the pointer stops after a few seconds. The same thing happened on Ubuntu 17.10. The solution is to update your kernel to 4.14 or higher (I updated mine to 4.15). Reboot and you should be fine. Currently I am using Arch linux with kernel 4.15. Works!

| improve this answer | |

As explained on this page, I got Ubuntu 18.04 LTS working on the same Asus machine by adding:


after quiet splash in /etc/default/grub.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.