I have a new computer with a Seagate ST500DM002 SATA internal hard drive.

I am trying to install Ubuntu 11.10 64-bit on it but the installer does not recognize/detect/see the hard drive. When I reach the Installation type step, the panel which is supposed to show devices and partitions looks empty.

sudo fdisk -l shows only /dev/sda1, the USB drive from which I am running the installation. I have already tried the following two solutions without any success:

  1. sudo apt-get remove dmraid
  2. Switch the SATA mode in the BIOS from IDE to AHCI

I am sure it's not a hardware related problem as I have already successfully installed another operating system on the same computer.

The output of sudo lshw -class storage -class disk follows:

  *-ide UNCLAIMED         
       description: IDE interface
       product: ASMedia Technology Inc.
       vendor: ASMedia Technology Inc.
       physical id: 0
       bus info: pci@0000:06:00.0
       version: 01
       width: 32 bits
       clock: 33MHz
       capabilities: ide msi pm pciexpress cap_list
       configuration: latency=0
       resources: ioport:d040(size=8) ioport:d030(size=4) ioport:d020(size=8) ioport:d010(size=4) ioport:d000(size=16) memory:fe400000-fe4001ff
       description: SATA controller
       product: 6 Series/C200 Series Chipset Family 6 port SATA AHCI Controller
       vendor: Intel Corporation
       physical id: 1f.2
       bus info: pci@0000:00:1f.2
       logical name: scsi1
       version: 05
       width: 32 bits
       clock: 66MHz
       capabilities: storage msi pm ahci_1.0 bus_master cap_list emulated
       configuration: driver=ahci latency=0
       resources: irq:44 ioport:f0b0(size=8) ioport:f0a0(size=4) ioport:f090(size=8) ioport:f080(size=4) ioport:f060(size=32) memory:fe705000-fe7057ff
          description: DVD-RAM writer
          product: DVDRAM GH22NS70
          vendor: HL-DT-ST
          physical id: 0.0.0
          bus info: scsi@1:0.0.0
          logical name: /dev/cdrom
          logical name: /dev/cdrw
          logical name: /dev/dvd
          logical name: /dev/dvdrw
          logical name: /dev/scd0
          logical name: /dev/sr0
          version: EX00
          capabilities: removable audio cd-r cd-rw dvd dvd-r dvd-ram
          configuration: ansiversion=5 status=nodisc
       physical id: 1
       bus info: usb@1:1.2
       logical name: scsi6
       capabilities: emulated scsi-host
       configuration: driver=usb-storage
          description: SCSI Disk
          physical id: 0.0.0
          bus info: scsi@6:0.0.0
          logical name: /dev/sda
          size: 14GiB (16GB)
          capabilities: partitioned partitioned:dos
          configuration: signature=0004e5a4
       physical id: 2
       bus info: usb@1:1.3
       logical name: scsi7
       capabilities: emulated scsi-host
       configuration: driver=usb-storage
          description: SCSI Disk
          product: Storage Device
          vendor: USB Mass
          physical id: 0.0.0
          bus info: scsi@7:0.0.0
          logical name: /dev/sdb
          capabilities: removable
             physical id: 0
             logical name: /dev/sdb

Any idea on what I could do to fix this problem?

  • What is your motherboard? Which SATA plug is it in, i.e., what color is it and where is it located?
    – Huckle
    Jan 27, 2012 at 16:45
  • @Huckle the motherboard is an ASRock H61M/U3S3. The SATA cable is black, the plug is white, named SATA3_0 and located nearby the RAM slots. Jan 27, 2012 at 17:42

7 Answers 7


As workaround I went in the BIOS and set the SATA Mode to "IDE" and the SATA3 Mode to "AHCI". After doing this the installer did detect the hard drive and installed Ubuntu alongside the other operating system.

I called it a workaround and not a fix because the other operating system won't load with the SATA3 Mode set to AHCI, so every time I need to switch OS I am forced to go in the BIOS and change the SATA3 Mode.

Another problem I had after applying the workaround was that the boot loader didn't show up on the next boot but the other operating started booting without any prompt. I've fixed this other problem by identifying the Ubuntu partition with:

sudo fdisk -l

(which was sda6) and then running:

sudo mount /dev/sda6 /mnt
sudo grub-install --root-directory=/mnt/ /dev/sda

I have exactly the same problem. I have the same ASRock motherboard and I tried different Linux distros without success. Finally Ubuntu 12.10 live usb booted correctly but my hard drive wasn't read.

The solution for me was to switch SATA connector: The hard disk was connected to the SATA3_0 connector and I switch it to one of the SATA2 connectors (SATA2_1 to be exact). It works now. I didn't check if Windows (which is installed in a partition of that disk) complains about this.


In my case (Dell Latitude 5501), the solution was to change SATA option from RAID to AHCI in BIOS settings.

  • in my case (ASUS W500G) what helped was to change it from IntelStorage to AHCI.
    – alfC
    Jan 25, 2023 at 16:14

The solution for me, when other approaches failed, was to run a BIOS update from Windows.

I was struggling with installing new Ubuntu alongside Windows 10 for one evening. The installer never found any other disks other than the USB drive. Tried everything that I could find posted as viable solutions in the interwebs:

  1. Disabling Windows fast boot (and hibernation).
  2. Disabling secure boot from BIOS.
  3. Changing SATA settings to ACHI.
  4. Removing Linux partitions (along all of my personal data) using tools in Windows.

...until I decided to run a BIOS update in Windows. That finally did the trick.

  • 2
    @Nmath It seems to me that most of the information in this answer is valuable, because it clarifies the conditions under which mjkvaak is recommending to attempt applying a BIOS update in order to solve the problem described in this question. So I think that removing it would radically alter this into what is effectively a different answer, by urging everyone who faces this problem to consider applying a BIOS update in Windows, rather than specifically users for whom the other named solutions have not worked. Sep 4, 2020 at 0:23

Some SATA ports have different controllers on the motherboard. Often times these extra ports are for eSATA, SATA3, SATA6, etc. When these ports are operating in new-ish modes then it is possible that Ubuntu wont understand how to use them. Switching SATA ports and changing the modes to the most universal often solves these types of problems.


Just for others who might stumble upon this, I had the same problem but it was due to my apple raid card. I had to remove it, unplug the iPass cable and plug it in the motherboard instead, and make sure I was using a SATA HDD (and not a SAS HDD), and i finally got the ubuntu installer to recognize the HDD.


I had the problem with a brand new laptop. I had to turn RAID off (wasn't using RAID anyways) by the solution from here:

  2. Enable Safe Boot (minimal)
  3. Reboot into UEFI/BIOS and change to AHCI
  4. Boot up into safe mode
  5. Run MSCONFIG and disable Safe Boot.
  6. Reboot

Internal HDD detection works after that.

  • Thanks a lot. Now both my Windows 10 and Fedora work properly. This is a working solution.
    – Reza Taba
    Aug 20, 2023 at 18:10

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .