My Linux system can't detect my wireless driver, so I have to load it manually.

I know what my driver is and tried this method:

Installation of the firmware is simply:

 % cp iwlwifi-7260-14.ucode /lib/firmware

You can now load the driver!

So I have successively copied the driver in the proper location /lib/firmware but I don't know what is meant by TO LOAD THE DRIVER. I thought that simply copying the driver into /lib/firmware would do the trick but NO it should be loaded into the kernel as is written in the instruction.

But how am I supposed to load this driver, what should I do to load it?

Here is what I did:

root@gNewSense:/home/georgi# modprobe -r iwlwifi
root@gNewSense:/home/georgi# modprobe iwlwifi
root@gNewSense:/home/georgi# lsmod | grep iwl
iwlwifi               162535  0 
mac80211              192806  1 iwlwifi
cfg80211              137243  2 mac80211,iwlwifi

$ lspci -nnk | grep 0280 -A3
08:00.0 Network controller [0280]: Intel Corporation Device [8086:08b2] (rev 83)
    Subsystem: Intel Corporation Device [8086:c270]
09:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller [10ec:8168] (rev 10)
    Subsystem: Lenovo Device [17aa:380d]

$ dmesg | grep iwl

$ rfkill list all
0: ideapad_wlan: Wireless LAN
    Soft blocked: no
    Hard blocked: no

Hopefully there is some clue in this output!

Excuse me for not mentioning it at the beginning but the GNU system that is gNewSense (it is Debian based) not Ubuntu. Anyway after reboot gives me this:

$ dmesg | grep iwl

$ uname -r

Also the official driver info in gNewSense pages is: it isn't work with a free driver

  • Please reboot and the edit to show: dmesg | grep iwl and also: uname -r
    – chili555
    Dec 28 '17 at 23:22
  • 1
    Your device is not supported until kernel version 3.10 and later. You are running 3.2 and not running Ubuntu. Sorry that we cannot help further. wireless.wiki.kernel.org/en/users/Drivers/iwlwifi
    – chili555
    Dec 28 '17 at 23:48
  • 1
    Maybe only It seems like the package linux-firmware is missing? try apt install linux-firmware and reboot. This worked for me. See: askubuntu.com/a/1064139/34298
    – rubo77
    Aug 10 '18 at 12:10
  • 1
    If you dual boot with windows 10 it might be that the wifi card is somehow blocked by windows. To avoid this happening use "shutdown /s /f /t 0" in a command shell in windows (I created a .bat file with this content, and so just can double click it to shutdown). I know it sounds ridiculous, but as soon as I do the full shutdown it works under Ubuntu...
    – JoeFox
    Aug 1 '21 at 12:04

You can load the driver with:

sudo modprobe iwlwifi

The driver iwlwifi and, indeed, the required firmware are included by default in all recent Ubuntu versions. If it is not loaded, something else is wrong.

Is yours really an iwlwifi device? Check:

lspci -nnk | grep 0280 -A3

Is the switch or key combination set to enable or disable the wireless? Check:

rfkill list all

Are there any clues in the log?

dmesg | grep iwl

After we find out more, I will edit this question to add additional troubleshooting steps.


The absolutely simplest way is to reboot. This ensures that all modules are loaded cleanly, on boot.

The other alternative is to manually remove it:

sudo modprobe -r iwlwifi

and reinsert it it

sudo modprobe iwlwifi

But iwlwifi typically has a couple of modules that depends on it, so it may be easier to reboot, if sudo modprobe -r iwlwifi returns any errors.

To see dependencies, run lsmod | grep iwl

[~]$ lsmod | grep iwl
iwlmvm                364544  0 
mac80211              782336  1 iwlmvm
iwlwifi               180224  1 iwlmvm
cfg80211              610304  3 iwlwifi,mac80211,iwlmvm

In this case iwlmvm depends on iwlwifi, so it has to be removed as well.

Not the answer you're looking for? Browse other questions tagged or ask your own question.