0

I installed Ubuntu 16.04 LTS alongside a Windows 10 on my new computer with a 256GB SSD and 1 TB HDD. Both Windows and Ubuntu are installed on partitions in the SSD. I wish to access files that are present on the HDD for storage.

On my previous computer when I had a dual-boot setup (both OS's on the same HDD in different partitions), I used to be able to access other files and partition directories in the same HDD from the File Manager itself when using Ubuntu.

I cannot do that in my current computer. I want to emphasize that I have already made the partitions and installed the operating systems. In most threads with situations similar to mine, the respective OP has posted the question before making the partition and asked for a guide thereon.

In one particular thread: Dual-booting Windows 10: Shared drive no longer accessible, I saw the command

sudo ntfsfix /dev/sdb1

Is it safe to run this command to solve my problem? I have read about this command creating problems with the HDD functioning.

I am also not sure of the name of the HDD and the partition. I have run

sudo lsblk -o NAME,SIZE,LABEL

and seen that the name of the 931.4GB partition is sda1. So, should I run

sudo ntfsfix /dev/sda1
  • The Linux ntfsfix, does not really do much, but it does turn on the chkdsk flag for Windows chkdsk which may be required. But if Windows 10 most often the issue is Windows fast start up which is just hibernation. And all NTFS partitions are in hibernated state and Linux NTFS driver will not mount NTFS that is hibernated to prevent damage. askubuntu.com/questions/843153/… and Windows updates may turn fast start back on, so you may need to turn it off again after Windows updates. – oldfred Dec 28 '17 at 19:53
  • I unchecked fast startup and run powercfg /h off to switch off hibernation in command prompt. I'm still not able to load the HDD partition. – Nihal Jain Dec 28 '17 at 20:13
  • What error do you get specifically when trying to "load" the partition? – jdwolf Dec 28 '17 at 20:49
  • There isn't an error. I'm not sure if load is the correct term to use in this context (excuse me please, I'm new here). I'm just unable to access the HDD for storage from the file manager as I'd normally expect to. – Nihal Jain Dec 28 '17 at 20:51
  • If fast start up off, and NTFS then Nautilus should auto mount partition. Better to label partitions so they mount by label rather than very long UUID. If internal drive, then you can mount with fstab, so already mounted when you reboot. Post this just to see partitions: sudo parted -l – oldfred Dec 28 '17 at 21:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.