I have a VirtualBox guest machine running Windows 10. On my host machine I have Ubuntu 17.04.

When I enter my guest machine, keys like the Super key and alt key are not grabbed so when I press the Super key, it opens the search menu in my host machine... And if I use Alt+Tab, it exits my guest machine window(and switches to another windows)..

I already have the "Auto Capture Keyboard" option on and I've also tried it with this option off..

By the way, it also happens when I'm controlling a remote computer with Teamviewer.. I guess it has something with it.

How can I fix this?

Thanks in advance.

  • This is really a problem dealing more with Windows and Virtualbox, than Ubuntu. That said, when I'm running a VM I have identical behaviour until I click once with my mouse inside the VM Window indicating to it that it should take control of the keyboard. I use KVM/QEMU rather than VB however. – Charles Green Dec 28 '17 at 16:39
  • @CharlesGreen Well, not the case for me.. – Ben Yaakobi Dec 28 '17 at 16:41
  • It's not an unknown situation for VM - this example is a Fedora host and an Ubuntu guest. I would suggest that you post this question on the Virtualbox Forums – Charles Green Dec 28 '17 at 16:55
  • @CharlesGreen I have added new information(about the TeamViewer) – Ben Yaakobi Dec 29 '17 at 12:57
  1. for the super key to work you need to press it twice - the first key press is caught by Ubuntu, the second one gets through to the guest OS.

  2. ALT+TAB might require the VM to be in full-screen mode

  • Doesn't work.. Also, alt+tab doesn't work in full screen mode either – Ben Yaakobi Dec 28 '17 at 18:09

Virtualbox doesn't capture certian modifier key combinations. However, there is a built in alternative.

At the top of the VM window, there is a tab marked "input". Under the keyboard menu is a list of key strokes for the modifiers. Most involve holding the "host key". On my machine the host key is Right ctrl

  • Alt + tab is not one of them though – Ben Yaakobi Dec 29 '17 at 15:09
  • Alt-tab works normally in my VirtualBox. version 5.1.30 – ravery Dec 29 '17 at 15:56

Solution: In my Laptop the Fn + Windows key combination does the trick and it is captured by the virtual machine

  • Same for me with the Windows key; how stupid! Doesn't help for things like Alt-Tab not being captured though :( Edit: might be related to Wayland. – c24w Mar 27 '20 at 10:45

My Dell Latitude E7450 has Ubuntu 17.10 as the host with a Windows 10 guest in VirtualBox (version 5.1.34). I experience similar issues as @Ben (alt + tab not working in the guest).

Solution: windows key + alt + tab cycles through the open programs (i.e., what I expect alt + tab to do).

Not sure how to get the windows key to bring up the start menu.


My problem was very specific. I'm not sure what was not good, probably something with the installation.. However, when I have reinstalled my host OS, it worked. Now it is working normally..

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.