1

Upon bootup gdm on my Ubuntu-Gnome 16.04 system (dual boot with Windows10) fails to present the login screen.

Previously, there was a Grub issue which I had to solve using Boot-Repair.

Now every time I boot up, I have to go into Recovery Mode, select Update Grub boot loader, and then resume booting up in normal mode. Only then the gdm login screen shows up.

Without this process I just get the greyish screen without the login box.

Once I booted normally - without going through that advanced boot menu option - and as usually got the blank gdm login screen. Just to see what happens, I pressed the space bar as if to select my login user, and typed in the password and hit enter. Interestingly, the system logged into my desktop!

Changing the display driver (upon advice from another forum) didn't work. GDM login screen still shows blank.

1

I've just seen this. It happened on a Dell Precision 5510 for no apparent reason. My fix eventually was to change back to lightdm as login DM. IMHO, there are some very weird undiagnosed problems in gdm. I read about 100 posts on the black–screen-of-gdm problem, a lot of us grasping at straws. Many voodoo suggestions.

For me, was not necessary mess with rescue or grub or what you mention. Could do Alt-Ctl-F2 and log in on VT2. From there, run

 startx

to get X11 session. That's how we always started in old days. Can run synaptic from a terminal and reinstall lightdm. Even if you have lightdm, reinstall good because it provokes a reconfiguration, where you can choose display for login. I needed GUI session because network would not start without it. I mean, I don't know how start network from terminal anymore. /sbin/ifup does no good anymore. New network stuff too fussy for my CLI skills.

I did that, but just checked and from VT2 you can cause same reconfiguration if you do already have lightdm. Run

dpkg-reconfigure lightdm

That opens a chooser for the login display, even in flat terminal.

If you cannot get into VT2, you could try single user mode to fix this. That must be less trouble than what you are trying. At boot,choose Advanced , select kernel and hit 'e'. Find linux line and change end to 'ro single' , cutting out splash quiet and whatnot .

This problem happened to me on a system where nothing new was installed and, so far as I know, nothing changed. Very baffling. I could see XFCE4 GUI splash from system starting. In VT2, running

/sbin/shutdown -r now

Would instantly cause the XFCE GUI splash to appear again. Hence I knew for sure the device still worked, but gdm could not talk to it.

Many people claim the Nvidia proprietary driver causes this, but I do not have that installed . I do have Intel/Nvidia graphics, however. It is apparently a known thing that Wayland display will not work with gdm in Ubuntu 17.10.

For some users, the black screen problem is more general related to video mode setting. If you have that problem, you will not see splash screen before gdm tries to start. For me, was simpler problem in dgm3. Mysterious.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.