2

I have a tri-boot computer (Ubuntu Mate 16.04.3LTS, Windows 7, Kali Linux). Until recently, grub menu showed at every boot just fine. However, tonight, I decided to exit Windows and load Ubuntu; I noticed that the grub menu never showed up and it just loaded automatically into Ubuntu. At first, I didn't think anything of it, because that's where I wanted. But now I can't get back into Windows.

I have tried:

  • holding the shift key during boot
  • running grub-update
  • interrupting the boot process with ctrl+alt+delete
  • performing boot-repair (log available at http://paste.ubuntu.com/26269885)
  • and changed the etc/default/grub line25 by deleting the '#' from front of line "GRUB_GFXMODE=640x480" (and running grub-update again)

I don't know if this is related but i also noticed that when I reboot my computer, the Dell logo doesn't show up on screen either

0

Reading information on pastebin, I found out that

GRUB_TIMEOUT=5

edit GRUB configutaion by running

gksudo gedit /etc/default/grub

in terminal. Enter your root password, then edit

GRUB_TIMEOUT=5

to

GRUB_TIMEOUT=10

Save the configuration file and run

sudo update-grub

This should solve your problem.

  • I'm not sure why the pastebin showed GRUB_TIMEOUT=5. I just checked that file and it says GRUB_TIMEOUT=10. And the problem still persists – Tricia Young Dec 28 '17 at 13:01
  • Try increasing that number to say 30 seconds. – TheOneAboveAll Dec 28 '17 at 15:26
  • @TriciaYoung | Answer provided by is same which I said, just it increases the timeout a bit more and uses GUI. You are requested to please accept my answer too and upvote it. – TheOneAboveAll Dec 28 '17 at 15:33
  • Actually it wasn't the time with the GUI. In the GUI there was no check mark in show menu. And I had increased the time in that file, which still had not worked. Furthermore, it only worked that one time. I have, since, rebooted the computer again, and it no longer is working. – Tricia Young Dec 28 '17 at 23:33
  • HAve you tried reinstalling GRUB – TheOneAboveAll Feb 18 '18 at 10:14
0

sudo add-apt-repository ppa:danielrichter2007/grub-customizer

sudo apt-get update

sudo apt-get install grub-customizer

click On Grub-Customizer and follow this image:

http://www3.0zz0.com/2017/12/28/11/496874360.png

  • Update: It worked once. But I have since restarted, and now it is back to loading automatically to Linux, with no grub menu. I went back into the grub customizer, and all the settings are the same as they were before when it worked. – Tricia Young Dec 28 '17 at 23:30
  • Do just as this picture : – Dz-Source Jan 1 '18 at 16:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.