0

I use an HP Zbook 14 G2 as my daily driver. It has an intel i5-5200U processor with hybrid graphics (Integrated Intel HD 5500 Broadwell GT2 and discrete radeon R7 m260 Opal Pro).

I used Ubuntu Gnome 17.04 with Gnome 3.24, and it had support for hybrid graphics, such that on the application menu I could pop out the menu and select "Launch using dedicated graphics card". In this way, I could easily launch applications such as gimp or vmware player using my discrete GPU.

However, I noticed that, when I did a fresh install for Ubuntu 17.10 (now using Gnome 3.26), I can no longer see that option when I right-click an application in the applications menu.

I am using vanilla gnome, not the modified version of Canonical***

Right here it is a post by OMG Ubuntu, through which I first knew about this option on Gnome 3.24 back then: http://www.omgubuntu.co.uk/2017/03/top-features-in-gnome-3-24

My question is: Is Gnome 3.26 still supporting this option, or is it just that Ubuntu folks disabled it for any reason? How can I get that option back or is there any alternative way to use my discrete GPU for my needed applications?

3
  • In KDE if there is only one graphics provider either because there only one GPU OR theres only one driver that supports PRIME it will not show the dgpu options. However the functionality still exists. PRIME is a feature of the kernel and managed by X. So any up to date system supports these features.
    – jdwolf
    Dec 27, 2017 at 23:08
  • I'm using Gnome, and I have my system as up-to-date as it can get. However, as I mentioned I can't (or in fact don't know how) get that feature to work. Dec 29, 2017 at 6:02
  • I'm quite sure GNOME still supports it however Ubuntu may have it disabled? I remember the days when dual graphics were really hard to get working but since PRIME its pretty easy. I don't use Ubuntu though. I can tell you it still works on Debian + KDE. So there's really no good reason it shouldn't work for you unless its just not detecting both GPUs.
    – jdwolf
    Dec 29, 2017 at 20:34

1 Answer 1

0

I've been trying to figure out this same problem. Saw this bug, seems like we need to use switcheroo-control:

https://bugs.launchpad.net/ubuntu/+source/nvidia-prime/+bug/1670379

Run sudo apt install switcheroo-control and reboot. The UI option should show up now.

As far as testing that this actually worked, I came across a command found in this thread which should show a dialogue of whether your graphics cards are in use or not:

https://ubuntuforums.org/showthread.php?t=1764765

sudo cat /sys/kernel/debug/vgaswitcheroo/switch

When i'm not using NVidia:

0:IGD:+:Pwr:0000:00:02.0
1:DIS: :DynOff:0000:01:00.0

When I am:

0:IGD:+:Pwr:0000:00:02.0
1:DIS: :DynPwr:0000:01:00.0
0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.