I always hit by some of the below error while installing any package with the connection with python3. But it works really fine with the python2 packages. Following is the error: The following packages have unmet dependencies:

cav-linux : Depends: libssl0.9.8 (>= 0.9.8m-1) but it is not installable
 python3-tk : Depends: blt (>= 2.4z-9) but it is not going to be installed
              Depends: tk8.6-blt2.5 (>= 2.5.3) but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution)


  • 1
    cav-linux and libssl10.9.8 are not Ubuntu packages. They are incompatible with your release of Ubuntu. Uninstall them and delete (or disable) whatever source you got them from. – user535733 Dec 27 '17 at 14:19
  • Can you please tell me how I can remove these errors from my PC. I don't really understand what they are? – Sanky Dec 28 '17 at 7:17
  • Thank you so much.' sudo apt-get -f install ' command solved my issue. – Sanky Dec 28 '17 at 7:27

This issue can be solved using following command:

sudo apt-get -f install

This command will remove all the error mentioned above.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.