3

I currently run Ubuntu 11.10 with Unity and FGLRX driver. I also use two monitors. Right now, if I maximize a window it does so across both screens. In addition, things like alt-tab will display split across both screens. It seems as if the computer is running with one giant desktop as opposed to two seperate desktops (workspaces?) as it did with the open source driver.

And no, I cannot go back to the open source drivers as they do not support hybrid graphics like the FGLRX drivers do.

1
  • Quick question - do the indicators on the top bar display twice (once on each monitor), or only on the right monitor?
    – pablomme
    Jan 27, 2012 at 12:25

1 Answer 1

7

I know the way to achieve the opposite effect (force single-monitor behaviour on a dual monitor), so assuming coherence the following should work for you:

  1. Install compizconfig-settings-manager
  2. Open it by typing ccsm into the dash
  3. Go to General options > display settings
  4. Do one of the following:
    1. If you have "Detect outputs" unchecked, check it again
    2. If not, uncheck it, and modify the outputs in the table at the bottom so that you have one for each monitor in the format <resolution-x>x<resolution-y>+<offset-x>+<offset-y>. For example 1280x1024+0+0 and 1280x1024+1280+0 for two monitors side by side at 1280x1024
  5. Press Alt+F2 and enter unity --replace so that compiz restarts. If compiz still refuses to apply the setting try logging out and back in

If 4.1 does not work, give 4.2 a try.

4
  • 1
    You are a lifesaver. This has solved my problem. Thank you so much :D Feb 3, 2012 at 8:13
  • Doesn't work on 14.10..
    – nbubis
    Dec 19, 2014 at 16:57
  • it works in 16.04
    – M.C.
    Dec 16, 2016 at 8:37
  • In 16.04, it is just under General Options
    – Arst
    Feb 17, 2017 at 4:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.