0

This question already has an answer here:

I am not able to install python-dev on my server. CPU - ARM64 OS - Ubuntu16.04.03

It failed due to unmet dependencies.

I have already tried for update,upgrade, force install and followed with multiple links to resolve. Looks issue specific to ARM64 with ubuntu16.04.3 ...

# sudo apt policy python-dev
python-dev:
  Installed: (none)
  Candidate: 2.7.11-1
  Version table:
     2.7.11-1 500
        500 http://us.ports.ubuntu.com/ubuntu-ports xenial/main arm64 Packages

I tried manually install dependent python pkg, but could not able to resolve dependency:

root@ubuntu:/home# sudo apt-get install python-dev
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 python-dev : Depends: libpython-dev (= 2.7.11-1) but it is not going to be installed
              Depends: python2.7-dev (>= 2.7.11-1~) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

root@ubuntu:/home# sudo apt-get install python2.7-dev 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 python2.7-dev : Depends: libpython2.7-dev (= 2.7.12-1ubuntu0~16.04.2) but it is not going to be installed
                 Depends: libpython2.7 (= 2.7.12-1ubuntu0~16.04.2) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

root@ubuntu:/home# sudo apt-get install libpython2.7 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libpython2.7 : Depends: libpython2.7-stdlib (= 2.7.12-1ubuntu0~16.04.1) but 2.7.12-1ubuntu0~16.04.2 is to be installed
E: Unable to correct problems, you have held broken packages.

root@ubuntu:/home# sudo apt-get install libpython2.7-stdlib 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
libpython2.7-stdlib is already the newest version (2.7.12-1ubuntu0~16.04.2).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

root@ubuntu:/home# sudo apt-get install libpython2.7 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libpython2.7 : Depends: libpython2.7-stdlib (= 2.7.12-1ubuntu0~16.04.1) but 2.7.12-1ubuntu0~16.04.2 is to be installed
E: Unable to correct problems, you have held broken packages.

Plz let me know if need to share more info.

Thanks

marked as duplicate by karel, Fabby, Eric Carvalho, Charles Green, George Udosen Dec 27 '17 at 21:42

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

0

Try running

 sudo apt-get install -f

I was facing similar problem which some other packages and it worked. I hope you have already ran this command.

  • 1
    yes, i have already tried sudo apt-get install -f , but still got same problem – khemendra Dec 27 '17 at 10:52
  • You have put sudo two times! – bhordupur Dec 27 '17 at 20:20

Not the answer you're looking for? Browse other questions tagged or ask your own question.