0

This question is an exact duplicate of:

This is a bit long, but please read through.

I have dual boot with windows 10 and Ubuntu 16.04(LTS). Originally, I had 2 partitions for my HD, one where windows is installed, and the other for my files. I took the second one, and shrank it, so I could allocate another partition for linux, so I can dual boot. I did it using manuals on line, and made sure I follow them exactly. Everything was successful for about 2 months.

Last night, I used Windows OS, and turned off the computer with no problems (don't know if there were any updates). Today, I turn up my computer, grub menu appears, and I select 'windows 10' - but windows won't go up, instead it goes into 'manufacturer recovery mode', and offers me some options (recover one partition, both or other).

So I chose to recover one partition on which I know windows is installed, and it recovered to Windows 7 (The manufacturer version I have on my PC), and basically the Windows OS is reinstalled, with everything that I had installed there deleted.

Does anyone has an idea why this is happening? I suspect this has something to do with an update done for Windows, but I don't know. Anyway, I didn't do anything that should lead to that (computer didn't crash or something like that).

Further more, this isn't the first time this has happened to me. 2 months ago, I also had dual boot like decribed above, and I got the same problem (windows went into recovery) - but that time I chose not to recover, and then grub stopped recognizing both my OS's and I had to do grub-rescue (like described here: grub rescue with dual boot 14.04) That time, I lost both my Os's, and ended up with formatting my entire HD to fix the problem. This time I 'chose smart' to recover only my windows partition, so while Windows is back to man-settings, the ubuntu is still working.

I have no idea why this is happening, I could really use your help. These are my system specs:

PC: Asus (about 5 years old)

CPU: Intel® Core™ i7-2670QM CPU @ 2.20GHz × 8

OS-type: 64-bit (both Windows and Linux)

HD: ~650G where ~200GB for windows OS (NTFS), ~300GB Files(NTFS), ~100GB Linux(ext2).

I have genuine windows 7 on my pc, which I upgraded legally via microsoft services.

Ubuntu is 16.04 LTS.

The first time it happened to me I had Windows 7 and Ubuntu 16.04 LTS, this time, Windows 10 and Ubuntu. At both times it happened from one day to the next, without me doing anything.

I've searched for an answer but I couldn't find one. Most questions relate to the case that on OS was intentionally deleted and the partition table got mixed - but this is not the case for me.

Would appreciate your help guys - I tried VM's and stuff and it didn't do the trick, and I like to make sure this won't happen again.

Edit: added the requested output:

Partition 4 does not start on physical sector boundary.

/dev/sda2 * 52430848 456257535 403826688 192.6G 7 HPFS/NTFS/exFAT

Thanks, Alon.

marked as duplicate by Elder Geek, Charles Green, George Udosen, Eric Carvalho, Panther Dec 28 '17 at 16:13

This question was marked as an exact duplicate of an existing question.

  • For some reason your system is booting from the manufacturers recovery partition. There may be an issue with the health of your hard drive or perhaps a stuck key on your keyboard that's requesting recovery at boot time. – Elder Geek Dec 26 '17 at 22:41
  • @Elder Geek: Nope. I ran a full test on HD like you suggested, and it says it's OK. also, I don't think it's a key being pressed, because the first time it happened to me, I canceled the recovery, and I had a major failure, so this wasn't a mistake I believe. – Alonbs Dec 27 '17 at 12:01
  • Ok, let's find out if you are right. Please edit the output of sudo fdisk -l | grep '*' | grep '/dev/' into your post. Thank you for helping us help you! – Elder Geek Dec 27 '17 at 13:41
  • Thanks for the feedback, but it's not the case of 'grub-rescue' - this was the case the first time it happened to me, but in this case the partitions aren't lost, ubuntu works fine, but windows(10) was reverted to manufacturer version (7) – Alonbs Dec 27 '17 at 19:15
  • Grub only boots working Windows. So if Windows needs chkdsk, you have to directly boot it and run chkdsk. Also Windows 10 will turn fast start up or always on hibernation back on with major updates. Again you have to directly boot Windows to turn it back off. If UEFI system, you can directly boot Windows from UEFI boot menu. But if BIOS/MBR, you have to temporarily install the Windows boot loader (fixMBR) from your Windows repair flash drive, fix Windows and then restore grub to MBR. – oldfred Dec 27 '17 at 20:39